Asterisk 13.25 behind NAT, UDPTL SDP contains Internal IP

Hi there,

I’m running Asterisk 13.25.0 (chan_sip), behind a NAT.

I’m trying to configure T.38 support, and it works, sort of, however the SDP Asterisk sends out when trying to RE-INVITE to UDPTL contains two c= lines, one with the external, and one with the internal IP.

I’ve set the following settings in sip.conf:

t38pt_udptl = yes
t38pt_usertpsource = yes

The SDP in the re-invite looks as follows:

o=root 1480777904 1480777905 IN IP4 <internal ip>
s=Asterisk PBX 13.25.0
c=IN IP4 <external ip>
t=0 0
m=image 4902 udptl t38
c=IN IP4 <internal ip>

Is there some way to get rid of the c= line with the internal IP?

I suspect this is the reason why we’re seeing A LOT of errors receiving faxes when T.38 is enabled.

I believe this should work, but it’s possible that there is a bug in chan_sip for this specific scenario. Unfortunately the chan_sip module is community supported, so if there is a bug I have no time frame on if or when it would be looked at. The chan_pjsip module is core supported and I’m fairly certain it would not suffer from this problem.

Fair game! We’ll upgrade to version 16 with PJSIP within the year anyway - was just hoping maybe this was a setting, or a known bug with a workaround or some such thing.

Thanks for the feedback!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.