Asterisk 13.21.1 and Cisco ATA 186 v3.2.1

This past weekend I updated a 4 year old build. I have a few small issues with things mostly related to sticking with the old stable install so long I forgot half of what I need to do to make these work –

But I do have a LARGE that I don’t understand – I have a Cisco ATA 186 that worked fine on the build that will not pass audio on 13.21.1 . While I have senndrpid set to NO I still have the Connect Line update prevented messages in the log, but I am not sure they are causing an issue, and the sip show peers indicate that the ATA is visible and reachable. It even rings when called, but as you can see below the RTP audio stream that worked previously does not now.

== Spawn extension (from-internal, 2152, 1) exited non-zero on 'SIP/2152-00000002'
    -- SIP/2152-00000002 Internal Gosub(func-apply-sipheaders,s,1) complete GOSUB_RETVAL=
    -- Called SIP/2152
    -- Connected line update to SIP/2101-00000001 prevented.
    -- SIP/2152-00000002 is ringing
       > 0xb7203cf0 -- Strict RTP learning after remote address set to: (called ip):4000
    -- Connected line update to SIP/2101-00000001 prevented.
    -- SIP/2152-00000002 answered SIP/2101-00000001
    -- Channel SIP/2152-00000002 joined 'simple_bridge' basic-bridge <5bf7252c-4421-4bce-b543-5007c37916ec>
    -- Channel SIP/2101-00000001 joined 'simple_bridge' basic-bridge <5bf7252c-4421-4bce-b543-5007c37916ec>
       > 0xb7415808 -- Strict RTP qualifying stream type: audio
       > 0xb7415808 -- Strict RTP switching source address to (Calling IP)
       > 0xb7415808 -- Strict RTP learning complete - Locking on source address (Calling IP):16474
    -- Channel SIP/2152-00000002 left 'simple_bridge' basic-bridge <5bf7252c-4421-4bce-b543-5007c37916ec>
    -- Channel SIP/2101-00000001 left 'simple_bridge' basic-bridge <5bf7252c-4421-4bce-b543-5007c37916ec>
  == Spawn extension (macro-dial-one, s, 52) exited non-zero on 'SIP/2101-00000001' in macro 'dial-one'
  == Spawn extension (macro-exten-vm, s, 14) exited non-zero on 'SIP/2101-00000001' in macro 'exten-vm'
  == Spawn extension (ext-local, 2152, 2) exited non-zero on 'SIP/2101-00000001'
    -- Executing [h@ext-local:1] Macro("SIP/2101-00000001", "hangupcall,") in new stack
    -- Executing [s@macro-hangupcall:1] GotoIf("SIP/2101-00000001", "1?theend") in new stack
    -- Goto (macro-hangupcall,s,3)
    -- Executing [s@macro-hangupcall:3] ExecIf("SIP/2101-00000001", "0?Set(CDR(recordingfile)=)") in new stack
    -- Executing [s@macro-hangupcall:4] Hangup("SIP/2101-00000001", "") in new stack
  == Spawn extension (macro-hangupcall, s, 4) exited non-zero on 'SIP/2101-00000001' in macro 'hangupcall'
  == Spawn extension (ext-local, h, 1) exited non-zero on 'SIP/2101-00000001'

Any direction is very much appreciated… Next step I think is to get a SIP trace.

Yes, you need to get a SIP trace and also an RTP trace using rtp set debug on. The log you’ve presented doesn’t really show anything except a normal call.

The lack of audio is on the 2150 side.

RTP Trace is attached, but to be honest doesn’t really tell me anything -

[2150]
Defaddr->IP : (null)
Prim.Transp. : UDP
Allowed.Trsp : UDP
Def. Username: 2150
SIP Options : 100rel replaces replace
Codecs : (ulaw|alaw|gsm|g726|g722)
Auto-Framing : No
Status : OK (528 ms)
Useragent : Cisco ATA 186 v3.2.1 atasip (050616A)
Reg. Contact : sip:2150@192.168.1.113:5060;user=phone;transport=udp

[2101]
Defaddr->IP : (null)
Prim.Transp. : UDP
Allowed.Trsp : UDP
Def. Username: 2101
SIP Options : (none)
Codecs : (ulaw|alaw|gsm|g726|g722)
Auto-Framing : No
Status : OK (26 ms)
Useragent : Linksys/SPA2102-5.2.5
Reg. Contact : sip:2101@10.0.0.194:5060

RPT_DEBUG.TXT (108.0 KB)

What is the configuration? What is the network layout? What is the SIP trace? (sip set debug on)

Good Morning,

Network Layout – Host is at RentPBX with a Public Static IP V4 address (Setup 5 years ago).

Two End points one in the US one Over seas. (Again this all worked till I decided to upgrade my 5 year old build).

Linux ipbx1.mydomain.net 2.6.32-754.el6.i686 #1 SMP Tue Jun 19 21:51:20 UTC 2018 i686 i686 i386 GNU/Linux

Host - Asterisk 13.21.1
(US) 2101 - Useragent : Linksys/SPA2102-5.2.5
(OS) 2150 - Useragent : Cisco ATA 186 v3.2.1 atasip (050616A)

Both End points are NAT behind Firewalls.

Have to wait for someone to come home at the other end.

Good afternoon - Set SIP and RTP trace on …

Extension 2150 Called Extension 2101 – Rings, Answer - Does not pass Audio …

trace20180719.txt (356.1 KB)

You haven’t provided the configuration either. Based on the information I can only guess that it is something related to the NAT or network configuration.

@jcolp

So first and for most thank you for looking at this with me !

When you say " haven’t provided the configuration" I guess I am not sure what you are looking for –

As I documented at the top of the file and else where in this thread. 

   2150 is a Cisco ATA attached to a DDWRT Firewall and NATed out to the ISP no clue who that would be. 
  2101 is a Linksys SPA attached to the DMZ of a Comcast Modem.

  Both register to the rebuilt Asterisk on a public IP at RentPBX.  2101 works and passes Audio, 2150 will not pass Audio after I upgraded from an Asterisk 11.n install to this version but worked fine before the software was upgraded.   If it was a new install I would suspect the DDWRT as blocking the inbound packets, but since it worked as is before the update I find that hard to believe. 

 I did see a 401 that does not make a lot of sense but I don't think it's related. 
[2018-07-19 15:28:24] VERBOSE[16166] chan_sip.c: Retransmitting #1 (NAT) to xxx.xxx.xxx.164:9156:
SIP/2.0 401 Unauthorized^M
 .

The contents of the relevant .conf files.

Here is the Extension that is causing me the trouble.

sip_additional.conf

[2150]
deny=0.0.0.0/0.0.0.0
secret=REDACTED
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
defaultuser=
trustrpid=yes
sendrpid=no
type=friend
session-timers=accept
nat=force_rport,comedia
port=5060
qualify=yes
qualifyfreq=3500
transport=udp
avpf=no
force_avp=no
icesupport=no
rtcp_mux=no
encryption=no
namedcallgroup=
namedpickupgroup=
dial=SIP/2150
mailbox=2150@default
permit=0.0.0.0/0.0.0.0
callerid=READACTED <2150>
callcounter=yes
faxdetect=no
cc_monitor_policy=generic

Here is the out of SIP Show settings -

ipbx1*CLI> sip show settings

Global Settings:

UDP Bindaddress: 0.0.0.0:5060
TCP SIP Bindaddress: Disabled
TLS SIP Bindaddress: Disabled
Videosupport: No
Textsupport: No
Ignore SDP sess. ver.: No
AutoCreate Peer: Off
Match Auth Username: Yes
Allow unknown access: No
Allow subscriptions: Yes
Allow overlap dialing: Yes
Allow promisc. redir: No
Enable call counters: No
SIP domain support: No
Path support : No
Realm. auth: No
Our auth realm asterisk
Use domains as realms: No
Call to non-local dom.: Yes
URI user is phone no: No
Always auth rejects: Yes
Direct RTP setup: No
User Agent: FPBX-13.0.192.19(13.21.1)
SDP Session Name: Asterisk PBX 13.21.1
SDP Owner Name: root
Reg. context: (not set)
Regexten on Qualify: No
Trust RPID: No
Send RPID: No
Legacy userfield parse: No
Send Diversion: Yes
Caller ID: Unknown
From: Domain:
Record SIP history: Off
Auth. Failure Events: Off
T.38 support: No
T.38 EC mode: Unknown
T.38 MaxDtgrm: 4294967295
SIP realtime: Disabled
Qualify Freq : 60000 ms
Q.850 Reason header: No
Store SIP_CAUSE: No

Network QoS Settings:

IP ToS SIP: CS3
IP ToS RTP audio: EF
IP ToS RTP video: AF41
IP ToS RTP text: CS0
802.1p CoS SIP: 4
802.1p CoS RTP audio: 5
802.1p CoS RTP video: 6
802.1p CoS RTP text: 5
Jitterbuffer enabled: No

Network Settings:

SIP address remapping: Disabled, no localnet list
Externhost:
Externaddr: (null)
Externrefresh: 10

Global Signalling Settings:

Codecs: (ulaw|alaw|gsm|g726|g722)
Relax DTMF: No
RFC2833 Compensation: No
Symmetric RTP: Yes
Compact SIP headers: No
RTP Keepalive: 60
RTP Timeout: 300
RTP Hold Timeout: 300
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: Yes
Pedantic SIP support: Yes
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Sub. min duration 60 secs
Sub. max duration: 3600 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Outbound reg. retry 403:No
Notify ringing state: Yes
Include CID: No
Notify hold state: Yes
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: No
Outb. proxy:
Session Timers: Accept
Session Refresher: uas
Session Expires: 1800 secs
Session Min-SE: 90 secs
Timer T1: 500
Timer T1 minimum: 100
Timer B: 32000
No premature media: Yes
Max forwards: 70

Default Settings:

Allowed transports: UDP
Outbound transport: UDP
Context: from-sip-external
Record on feature: automon
Record off feature: automon
Force rport: Yes
DTMF: rfc2833
Qualify: 0
Keepalive: 0
Use ClientCode: No
Progress inband: No
Language: en
Tone zone:
MOH Interpret: default
MOH Suggest:
Voice Mail Extension: *97
RTCP Multiplexing: No

Made a small change, from Public to Static IP reflected here, but no real change with the older Cisco ATA. no audio since I updated the Asterisk from 11.n to 13.n

Network Settings:
---------------------------
  SIP address remapping:  Enabled using externaddr
  Externhost:             <none>
  Externaddr:             xx.xxx.xxx.154:0
  Externrefresh:          10
  Localnet:               xx.xxx.xxx.0/255.255.255.0

Good day

What about using TCP and ensuring Asterisk has the correct static address. From this page. https://serverfault.com/questions/392979/asterisk-sip-2-0-401-unauthorized

@Allan1

Hi thank you for your input.

This older Cisco ATA 186 does not have TCP capabilities to my knowledge but I will do some digging.

Yes I am am sure about the Static IP assignment it’s been mine for five years now, and this ATA was connected to this host on the Older Asterisk 11 build with no issues. An the ATA has not been touched since the upgrade. Additionally the SIP session Registers and looks okay it’s the RTP audio path that is not working.

Just for clarity, the static IP I was referring to is in the settings for your new Asterisk system.

Yes I understood that -

Host is at RentPBX is the host and I have had a static IP…

Both SOHO Locations are at the mercy of the ISP provider.

Nothing changed at any of the three sites, only the build of Asterisk changed.