Asterisk 13.15 Ubuntu 16.0.4 Installation Failure


I tried “apt-get install asterisk”, but asterisk didn’t start and I wasn’t sure what version that would give me, so I removed it, and tried the following sequence of commands as per the help (I think):

apt-get install build-essential
tar -zxvf asterisk-13-current.tar.gz
cd asterisk-13.15.0/
cd contrib/scripts
./install_prereq install
44 OK
cd …/…
./configure --with-pjproject-bundled
make install
make samples
make config
make install-logrotate
/etc/init.d/asterisk status
/etc/init.d/asterisk start

All seemed fine until the end - Asterisk doesn’t seem to start and the last 2 commands don’t display any output. Adding some comments to /etc/init.d/asterisk I see that it stops at this line:

. /lib/lsb/init-functions

I’m not sure what that does, or if I’ve missed installing a dependency. Any help would be greatly appreciated.


Ubuntu 16.04 uses systemd, as a result the included init.d script may not work and a systemd service file is not present. You may be able to find one from elsewhere and use it.