Asterisk + Chan_SCCP + CISCO 7940

Hi all,

[color=#BF0000] Please tell me if the cisco 7940 SCCP loaded phone works with asterisk using skinny channel? If so please guide me.[/color]

   I have tried connecting cisco 7940 to asterisk using SIP firmware and successfully connected  :smiley: .Now i am trying to connect with SCCP firmware but facing some issues and i am not sure that the way i am working is correct. Please verify it and provide me a solution.

I have bought a new cisco 7940 phone which is by default loaded SCCP firmware. I configured the phone to connect my TFTP server and below given are the configuration files.

The configurations are given below

XMLDefault.cnf.xml configuration

<Default> <callManagerGroup> <members> <member priority="0"> <callManager> <ports> <ethernetPhonePort>2000</ethernetPhonePort> </ports> <processNodeName>my Asterisk IP address</processNodeName> </callManager> </member> </members> </callManagerGroup> </Default>

Dialplan.xml configuration

<DIALTEMPLATE> <TEMPLATE MATCH="*" Timeout="5"/> <!-- Anything else --> </DIALTEMPLATE>

CTLSEP002584A2057C.tlv file is an empty file.

Since the firmware is already installed i used minimum three files required files for making/receiving basic calls from Cisco Phones. Which are given above.

My Asterisk configuration


bindaddr=My asterisk server ip address ; Address to bind to
bindport=2000 ; Port to bind to, default tcp/2000
dateformat=M-D-Y ; M,D,Y in any order (6 chars max)
; “A” may also be used, but it must be at the end.
; Use M for month, D for day, Y for year, A for 12-hour time.

callerid="Mathan 108"
linelabel=“Mathan” ; Displays next to the line button on 7940’s and 7960s

callerid="Bhanu 109"
linelabel=“Bhanu” ; Displays next to the line button on 7940’s and 7960s


device=SEPmacaddress of the phone

extension.conf configurations

exten => 108,1,Verbose(1,Extension 108)
exten => 108,n,Dial(Skinny/108,30)
exten => 108,n,Hangup()

exten => 109,1,Verbose(1,Extension 109)
exten => 109,n,Dial(Skinny/109,30)
exten => 109,n,Hangup()[/code]

I have restarted both asterisk and my phone once configured.

Output for show skinny lines is given below

[code]magesh*CLI> skinny show lines
Name Device Name Instance Label

108 Not connected 0 "Mathan"
109 Not connected 0 “Bhanu” [/code]

Output for show skinny devices is given below

[code]magesh*CLI> skinny show devices
Name DeviceId IP Type R NL

support SEP002584A2057C No Device N 2

On restarting the phone my phone is not getting register. Please help me out in resolving this issue.
Please assist me with configuration files if i am wrong.

Thanks for time and consideration,

Thank you Jesus for this post.

I’ve been struggling around for the better part of a week trying to find a working skinny.conf that worked with the 1.8 SKINNY drivers. My 7910s are all back on line thanks to you!