Asterisk -- can only hear one way

Hi all
This is my first post and first time using Asterisk.

I am currently running an Ubuntu 8.04 box and installed asterisk and Digium Asterisk-GUI (don’t remember what version the GUI is. Is there a way to check?)

I have successfully configured my Asterisk installation and I can access it via html with the GUI.

Now the prob is me and a colleague are using Zoiper (soft phone) to test the system with.
Both softphones have registered with the asterisk box successfully. Asterisk shows both extensions are connected and ready. When we place a call, Asterisk is again right on top of that and updates the status for the extensions. The prob is when my colleague calls me, I am able to hear him, but he can’t hear me. We have triple checked his settings for Zoiper and it all checks out fine. His sound does work cuz he plays games with no prob.

My computer is WinXP and his is WinVista… yes I know… Vista :frowning: Come to think of it, could it be a Vista issue?

If there is any further info you require (config files, asterisk settings, etc…) I’d be happy to provide.


Found the version of the GUI

Asterisk GUI-version : SVN-branch-2.0-r4962

I found this in Asterisk itself, in the Users section-> Edit user:

In this window, there is a NAT checkbox that reads: NAT: Try this setting when Asterisk is on a public IP, communicating with devices hidden behind a NAT device (broadband router). If you have one-way audio problems, you usually have problems with your NAT configuration or your firewall’s support of SIP+RTP ports.

Since I am experiencing one-way audio, it seems to be a NAT issue. Can anyone explain to me how NAT should be configured?

On your firewall open up the ports you have defined in rtp.conf, portforward port 5060, 5061 for SIP, SIPS and the range you have defined in rtp.conf to your Asterisk-IP.
In sip.conf, if needed, define externip=… and localnet=…