Asterisk 1.2 faxdetect false detects

Hi, Can anyone help on the following question.

I have asterisk 1.2.13 with a sangoma e1 card connected to our 23 channel isdn30e line. Phones are gxp2000.

22 of the isdn ddi numbers are for voice, and one is for incoming faxes.

My problem is I have to use faxdetect=both so asterisk detect the fax and turns of the echo canceller. This does it for all channels. Doing this sometimes people who are talking to us on the phone get detected as a fax and the customer gets routed to the fax extension which cuts them off and gives them the fax tone.!

I would be quite happy to have the incoming extension for the fax just dial the iaxmodem-hylafax without any fax detect but what command could I use to disable the echo canceller on the current channel otherwise the fax would fail due to the audio being messed up. ??

Somthing like the following i.e. incoming fax no is 123456

exten 123456,1,Answer
exten 123457,3,Dial(iaxmodem)



I have just found mention of the zapec command to turn off echo cancelation.

Does anyone know if I could use it in the following way on our sangoma a101 isdn30 e1 line.

I would have faxdetect = NO

and in extensions.conf for the context our incoming ddi would endup in the following context.


exten n,1,zapec - to turn echo can. off.
exten n,2,DIal(iaxmodem etc)