Anyone successfully running Asterisk on Lion?

Sorry to keep dredging this up, but I’m desperately trying to develop an Asterisk application on my local machine of choice, which is running OSX 10.7. I’ve tried Asterisk 1.8.8+ with no luck.

Has anyone successfully installed Asterisk on OS X Lion? If so, which version and any hacks or specific configuration?

Thanks for any encouragement.

[code]$ uname -a
Darwin Thors-MacBook-Air.local 11.3.0 Darwin Kernel Version 11.3.0: Thu Jan 12 18:47:41 PST 2012; root:xnu-1699.24.23~1/RELEASE_X86_64 x86_64

$ gcc -v
gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.1.00)

*CLI> core show version Asterisk built by thor @ Thors-MacBook-Air.local on a x86_64 running Darwin on 2012-03-05 06:06:39 UTC

to build asterisk- I used:

  $ ./configure --prefix=$HOME/asterisk1.8 --without-netsnmp
  $ make
  $ make install
  $ make samples
  $ ~/asterisk1.8/sbin/asterisk -cvvvvvvv

If this does not work for you, you can always consider running Linux under Virtualbox.

Thanks for replying, you give me hope! But arg, still getting the same error:

[code]dyld: Symbol not found: ___ast_adsi_available
Referenced from: /Users/kevintriplett/asterisk1.8/sbin/asterisk
Expected in: flat namespace

Trace/BPT trap: 5

The absolute only difference is my LLVM version is different:

$ gcc -v gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)
versus your build 2336.1.0.

I may try the virtual machine route, but I’m developing an app using Adhearsion, and the RoR database is on the Mac side of the wall. So Adhearsion would have to bridge the two systems somehow.

thor, have you installed any kind of hardware emulator, like for ADSI? Also, what processor is in your MB Air?

Thanks for your help on this, much appreciated!

[code]Hardware Overview:

Model Name: MacBook Air
Model Identifier: MacBookAir4,2
Processor Name: Intel Core i5
Processor Speed: 1.7 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 4 GB[/code]

Did nothing for ADSI. Try unpacking the source again. I think ‘make clean’ does not clean everything.