AMI Originate Call


I found several ways to make an outbound call.
But I couldn’t make it.
I’m just trying to call my cellphone. Bu it doesn’t work.

As I understand I have to create a new Context for making outbound calls.

In Freepbx/Trunk settings screen I defined my SIP Trunk. And I tried to make a call with using a softphone(X-Lite) and it works.

Because “default” context doesn’t work.

By the way I setup AsteriskNow.

Can you please give me a sample dialplan for making outboundcalls wtih using an UMTH company SIP server.

Thanks ver much in advance.

You should post here:
If you want to create a peer for SIP trunk:
This is a basic peer configuration.

[siptrunk] username=xxx secret=xxx type=peer disallow=all allow=ulaw allow=alaw context=my-context
For make outbound calls…

[context-phones] exten => _15.,1,Dial(SIP/${EXTEN}@siptrunk) exten => _15.,n,Hungup()
15 -> for celphone by example… you have to fit to your number.

Sorry for the location.

I’ve changed like your offer sadzas.
And I tried to make a call again.

I got the following error immediately when I start to call:

“Channel SIP/MySIP-08593a90 was never answered”

By the way my context exactly like this:

Thanks a lot…

You must give more information.

What the log says?
Did you try a ethereal capture?

I found in the log:

[Oct 6 16:47:24] WARNING[3454] chan_sip.c: Received response: “Forbidden” from ‘“AMI Connector Example” sip:Unknown@;tag=as06065ab2’
[Oct 6 16:47:24] VERBOSE[3548] logger.c: > Channel SIP/MySIP-0905af98 was never answered.

And I googled the error and find that the reason was CallerID so I tried my SIP company’s CallerID and I don’t know how I change it…
And CallerID can change on different projects…

Then it worked. But it immediately hangups.

look, what I tell you (basic configuration) is correct and it shoul work. I dont understand your scheme, but it will help:

verbosity: 15
ethereal capture.
try with this: tshark src or dst port 5060 -w file.cap -S

can you point somewhere or explain it detail please.