407 Proxy Authentication Required - * 1.2 - Aastra 9112i

Hi guys,

I know there are plenty of posts on this problem and I have tried them all and still having problems with incoming calls. They are failing with the 407 message on the SIP INVITE. I have two SIP phones set up as extensions to Asterisk and can ring internally fine. I ring the Asterisk demo no worries. I can also ring outbound any number fine, so its only on inbound I am having problems. I have a very simple sip.conf and extensions.conf.



callerid=“1234” <1234>
secret=(same password as above)

I have been on to blueface about this and this is the config suggested with a few additions myself to try and get it working. Initially my blueface account didn’t accept a username and password but were added in to try to fix the problem.



I’m using Asterisk 1.2.18 on FC6.
There no Nat to consider
Thats it.

Of course there is extra configurations for outbound but this is fine and the names used are different to ensue no conflict. I really don’t know what else to try, so any suggestions appreciated.



Ok I started from scratch…

I just added the config for incoming calls like outlined on blueface site in sip.conf and extensions.conf and it worked!!! Then as soon as I added in the config for outgoing calls in sip.conf I can’t recieve any more incoming calls but can make out going. If I block out the outgoing lines I can recieve incoming calls again.

this is my sip.conf


[mapflow3] ;with this included cannot recieve incoming


II guess there most be a conflict somewhere can you see where?

Please help, this is driving me insane

Jesus for an open source product the lack of response is disappointing. I would have expected some sort of response after two days.

Anyway I have solved the conflict I was having. The conflict was in my extensions.conf file. For incoming calls I needed to specify a different account to the one I was using for outgoing specified in sip.conf. Problem solved.

If anyone wants more clarification on this let me know and I’ll post more details… Thanks for… Well thanks for reading I suppose… :unamused: Take care…


[quote]Jesus for an open source product the lack of response is disappointing. I would have expected some sort of response after two days.

Hi that is a problem with open source, You do have to do much of the work your self. and provide as much concise information as possible, And to be honest the post title is a litle misleading as the problem had nothing todo with a aastra handset. it was todo with your supplier.
This would hae caused most people who dont know or use the 9112i to ignore the post.

Also posting debug information helps as it lets us see whats happening.


I see where your coming from. Either way it was nice to get some response!

That’s kind of the blessing/curse with Asterisk the configuration is so loose at the moment when things are not working it can be a nightmare to figure out where the problem arrives, thus when looking for help posting irrelevant information on the off chance that the problem may discovered. Even looking at other peoples problems that are posted, it isn’t easy to see where a problem lies looking at lines and lines of info.

Next time (which should be soon no doubt!) I’ll try to be more concise but my gut tells me I’ll be sorting most things off my own bat.

Take care


But it does make it possible to see whats happening and in 99% of cases you can see whats going on.

I dont think so, If you look here most get answered and yes almost all ask for more information, But thats the only way to fault find a system. Also have a look at the number of posts of the active members you will see some big numbers. and many of these are helping out people who are just starting.


Sounds promising. Thank Ian