2 nic asterisk sip/rtp oddity

Hello All,

  • Asterisk 11.x , fresh install

Been using asterisk for about 5 years now,and always learning. My new Asterisk 11 setup on CentOS6 installed via rpms from asterisk/digium repos.

This is a two nic server that is also a linux terminal server,just for completeness.
eth0= internal interface
eth1=external interface

I have been tryin to learn some new things in regards to QoS and the miriad of traffic shaping docs that are out there.

In doing a lot of of tcpdump,and Wireshark captures ,come to find out, that when traffic is passed from eth0,to eth1 looking at Wireshark the udp 'port(s) shows from sip(eth0) > STUN(eth1) and RTP(eth0), to > CLASSIC(eth1).

I am thinking due to tthis situation all of the classic Qos/traffic shaping scripts that are out there is not,working,due to the fact the packets being passed are being tagged differently of being the standrard SIP/RTP,by the time they go out eth1(external interface)…
The voice quality is pretty good,but from time to time, i do get some voice breakup,on the receiver’s end. I can always hear who i am talking to fine.

I have tried using both NAT and No Nat in the sip settings(I am using FreePBX GUI),in conjunction with asterisk. They both work fine but makes no difference in regards to the udp packets being tagged diffrently when being passed from eth0, to eth1.

Also for completeness I have only tried using my Android Google Voice account.Could this be part of the situation,I am seeing here.

Has anyone experienced this situation,and if so,how do i setup any of the ,example sipshaper scritps to work?

Thank You,