Zoiper shows “Service or Option unavailable” sending fax

I was using 32 bit windows and Linux OS as two zoiper clients and Asterisk as the server. I am using AstWind 0.66b which is asterisk for windows.
I could register and establish audio calls successfully. While sending tiff file as a fax from windows to linux using Zoiper, after selecting the tiff file, a ring goes to other end. After the call is accepted, the sender Zoiper shows the notification “Service or Option is unavailable” What may be the reason of that error notification ? Do you have any idea ?

Asterisk for Windows is based on a very obsolete version of Asterisk.

How does the phone try to send the image? Asterisk doesn’t do file transfers and T.38 would need to be explicitly enabled.

Yes I have enabled T.38 in the sip.conf. I have followed the instructions those are found in different forums for asterisk. Somebody suggested that it is a issue of codec. But i have checked that i allowed those u-law, a-law and gsm codec.

Another important thing is that i checked the history in zoiper and showed that “bearer capability unavailable” just before the “Service or Option unavailable” option. So one suggested that may be windows firewall is the reason. Do you think it can be the problem? or, Any thing do you suggest me to do?

I had tried to install latest asterisk for linux redhat or ubuntu… it tried to download several parts from mirror, but failed. I have tried other several ways, but did not see any success.

Thank you.

gsm is totally unsuitable for fax, if that is what you are trying to do, although I suspect that your issue is the IAX equivalent of T.38.

I have allowed ulaw, alaw and gsm… And i am not using IAX rather using simple sip for fax.

Now i am using 2 windows OS and installed zoiper there. Now the error “Service or Option unavailable” is not showing. But I am getting the notification “Bearer Capabiliy unavailable”.
While I send a fax i send an invitation. When it is accepted i get OK 200. Then from my side a request goes INVITE (i mean re-invite here). But in response a message i get from the server with status 488 (indicating Not Acceptable here). In the mean time asterisk send BYE to the other end and the call hangs up. I see “Bearer Capability unavailable” notification in my side.