XM Satellite Radio via ANTEX XM-100 for music on hold

Has anybody set up MOH using XM Satellite Radio via ANTEX XM-100? I guess that my only option is using a sound card in my server, and piping the audio in via 1/8 jack. I am curious if the data port on the ANTEX XM-100 could be used? I have a 1U Dell server with both PCI slots being used, so I am going to have to use an external sound card.

I have found the RS 232 command specs, so the I guess that you could write a script to interface with the comm port to change the channels. I guess that I am going to order one, and I will post back my experiences.

Don’t forget that for the purposes of licensing, MOH is a public broadcast, and that you have to pay license fees to ASCAP, and BMI to use music you’d hear on XM radio channels.

In order to use XM radio as a music source, you would need to subscribe to their XM for Business plan. They build in the license fees to the subscription cost.

Click here for more info.


Yes we did. Thanks.

Here is a clip from the wiki on what you can do

Using a sound card as the source.

This is usefull for such things as FM tuners or other external audio feeds (XM Satellite Radio anyone?).

  1. Add the following into musiconhold.conf:


In /var/lib/asterisk/mohmp3 therre should be at least one mp3 file.

  1. Create script file /usr/sbin/ast-playlinein and make it executable:

/usr/bin/arecord -q -c 1 -r 8000 --buffer-size=2048 -f S16_LE -t raw

  1. Then you need to configure your mixer to turn on LINE-IN capturing.
    You can then plug into the line-in port your FM-tuner or external audio player.

Don’t forget to reload (should be enough) asterisk.

Additional note by crees (at) bearrivernet (dot) net
Trixbox users may notice that this does not work. Your MOH will start and stop immediatly. This is due to asterisk not having rights to the /dev/snd folder and files. You will need to create a new group (i called audio) and then allow root and asterisk to be part of it. then chmod the directory so everyone can have access to read and write these files. (in /dev/snd ) You then will need to adjust the mixer via alsamixer command. I ended up using the mic in on my sound card since line in on mine was not working. Look for the line in capt and line in or mic in , mic capture levels and adjust them accordingly. You may want to unmute (pushing m on slider) and move all sliders up and see which one controls the volume.

’ courtesy of,

Hardware and other goodies