Why callerid from console.conf became anonymous?

I set callerid in console.conf

callerid = MyName Here <(256) 428-6000>

but instead of “My name” appear this

when I call from console to one phone, I have restarted Asterisk and set core set debug -1 but I cannot see any error message

I tried also

callerid = "MyName Here" <(256) 428-6000>

But same results

Try using it in pjsip.conf under your outbound endpoint:

[1001]
type=endpoint
callerid=pnirru<(256) 428-6000>

1 Like

Caller ID is the caller ID for the source. Setting it on the outgoing endpoint will have no effect.

I see console more as a proof of concept driver than a production one and I don’t think it gets any real maintenance.

Is it possible that you have set some caller ID presentation restrictions?

Space is s difficult character in caller ID, as it has to be escaped when being sent over SIP.

1 Like

Is not the callerid of and endpoint or sip phone, is callerid of console(console.conf)

The callerid with spaces in sip.conf works fine, only the callerid of console.conf became anonymous

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.