wctdm24xxp0: Missed interrupt. Increasing latency

I am using asterisk on several machines, running a version of Mandriva
one machine runs Mandriva 2007/x86_64 with a wctdm24xxxp
the other runs on Mandriva2008.1/x86_32 with a wctdm800p
zaptel-1.4.11 & asterisk-

since I updated to the last versions of zaptel & asterisk
the message:
wctdm24xxp0: Missed interrupt. Increasing latency etc.
ending with:
kernel: wctdm24xxp0: Missed interrupt. Increasing latency to 32 ms in order to compensate.
kernel: wctdm24xxp0: ERROR: Unable to service card within 30 ms and unable to further increase latency.

and no more incoming telephone lines
with the exeption of returning to a previous version of zaptel/asterisk any solution will be apreciated

The latency increases whenever the wctdm4xxp driver can’t interrupt the CPU due to another device driver interrupting the CPU at that time. Since it is reaching the maximum latency(think of it as a buffer) this means that another devices driver is interrupting for too long. Disable anything not needed on the system. You may even see better results with a distribution such as Debian.

I understand the latency increase is related to missing an interrupt - however I also tried getting the interrupt serviced by another cpu-core with no apparent change.
On previous versions of zaptel one call might be dropped by a missed interrupt – now all calls will be dropped and new incoming call-request find a no-service/no-answer tone.
I am kind of baffled why this only occurs with the wctdm2400p driver, we also have four locations where the wctdm400p is working happily without any drops and using the same versions of Mandriva, zaptel and Asterisk.
Is there a way to raise the priority handling of the interrupt – only the handling of another (lower) interrupt can cause loss of another interrupt (I think)
The keyboard, floppy, parrallel and serial ports are already disabled and only timer, video, harddisk, usb and network cards are used.

any solution will be apreciated

I had these issues with TDM800 cards, I can able to make outgoing calls but incoming not detecting. It is interesting that some kind of motherboards works great but some other misses the interrupt. It is basically an architecture design issue rather than driver I think.

I have tried almost all asterisk versions and linux distros to solve but the specific hardware shows same error with TDM800 card.

Digium has to seriously look into this issue.