VoiceMail


#1

Hello again!

Alright, one more question for all you asterisk expert.

Is there any way to reduce the time when you access your mailbox… I feel like I have to wait forever before I can enter my password…

If you know the answer or hint or anything, let me know!

Thank’s


#2

Forget about this one too, I found it!

If anyone is interested, my problem was that when accessing my mailbox, it took between 4 and 5 seconds before I could hear the: Please enter your password…

Now I changed gateway, and it’s fast as hell!! … Awesome! … So bascically, the gateway that you use is important!


#3

or you can hit the # key after entering the mailbox, that ‘ends’ the digit string.

not sure if you’ve tried this, but our entire company basically uses the email capabilities to email the entire voicemail as a WAV attachment. our users love it because all the info is right there in the email, and they can easily get to VM from remote locations. it’s also nice to be able to forward a VM as easily as you can forward an email…

not saying the VM system isn’t nice - it’s friggin great!

anyways, just thought i’d mention the email functions, try them out if you haven’t.


#4

… The way I programmed my VoiceMail in my dialplan, when you pickup the phone and press *98, it automatically ask you for your password because the system knows already which extension you’re at… If it wasn’t programmed like that, the same problem would have occured but instead of waiting 4-5 seconds before entering my password, I would have wait 4-5 seconds to enter my extension… All the * features programmed into my DialPlan took 4-5 seconds before it got processed… But now since I changed Gateways, all these * features are fast as hell… like no wait whatsoever… you press *98, boom, right away the VoiceMail picks-up… it’s awesome!


#5

Don I was wondering how you did this exactly as I am interested in this. Thank you!


#6

Simple as:

exten => *98,1,Answer
exten => *98,2,VoiceMailMain(${CALLERID(number}@default)
exten => *98,3,Hangup

And of course you have to have all the extensions into your voicemail.conf under the default context…


#7

[quote=“DonFoucker”]exten => *98,1,Answer
exten => *98,2,VoiceMailMain(${CALLERID(number}@default)
exten => *98,3,Hangup[/quote]
pinched straight from the AMP/FreePBX config files (albeit with a *97/*98 swap) :smiley:


#8

[quote=“baconbuttie”][quote=“DonFoucker”]exten => *98,1,Answer
exten => *98,2,VoiceMailMain(${CALLERID(number}@default)
exten => *98,3,Hangup[/quote]
pinched straight from the AMP/FreePBX config files (albeit with a *97/*98 swap) :smiley:[/quote]

Really? Humm… I don’t have AAH handy but damn, I had to think that out… I should have looked in there, it would have made my life simpler…


#9

[quote=“DonFoucker”]Simple as:

exten => *98,1,Answer
exten => *98,2,VoiceMailMain(${CALLERID(number}@default)
exten => *98,3,Hangup

And of course you have to have all the extensions into your voicemail.conf under the default context…[/quote]

Thanks, this helpes me alot.
Is it also possible to let the system automatically fill in the paswoord?
I use the same password as my extensions?


#10

I found the solution. Simply add an s before the extension for skipping the password.

exten => *98,1,Answer
exten => *98,2,VoiceMailMain(s${CALLERID(number}@default)
exten => *98,3,Hangup


#11

I had a similar issue with IVR, re the 4 second timeout, but I figured out what it was. My IVR had options 1 & 2. If the user hit one, it went straight to the option. If they hit 2, I’d get the delay. Reason? I also have extentions 200-250. * was waiting to see if I added more digits. Therefore, to avoid the delay, chose a number range that doesn’t clash with any other extensions. The * prefix is a quick fix.

Regards