Voicemail to Email issue

Hi,

I am trying to add ID’s so that when I receive a voicemail I receive an email.
Its already sending email to “abc@xyz” but when I try to add another ID “def@xyz” (of same domain) in aliases, it bounces back.

Do I have to add the ID somewhere else too?

I am using postfix to send mails.

xyz-voip postfix/smtp[10063]: 895F1104074F: to=<abc@xyz.com>, orig_to=<root@localhost>, relay=smtp.asia.secureserver.net[182.50.144.66]:25, delay=2.7, delays=0/0/0.65/2, dsn=2.0.0, status=sent (250 2.0.0 Kspr1u00h0wUf5m01 - Kspr1u00h0wUf5m01spseP mail accepted for delivery)

xyz-voip postfix/smtp[9695]: 62CA61040750: to=<def@xyz.com>, relay=smtp.asia.secureserver.net[182.50.144.66]:25, delay=2.6, delays=0.9/0/0.65/1, dsn=5.2.0, status=bounced (host smtp.asia.secureserver.net[182.50.144.66] said: 550 5.2.0 <root@asterisk.localhost> From: Domain is invalid. Please provide a valid From: IB506 <http://x.co/srbounce> (in reply to end of DATA command))

Also is it possible to send mails to different ID’s according to extensions?

The bounce you have shared is because your from address is invalid.

Check your ‘serveremail’ setting in voicemail.conf and make sure it is valid.

As to your question yes you can direct voicemail to email to an alias.

I’m sure and double checked the email ID, its correct.

Sorry…from address or to address? Configuration in voicemail.config is same for all

voicemail.conf

[general]
format = wav49|gsm|wav
attach = yes
serveremail = no-reply@xyz.com
fromstring=XYZ
sendvoicemail = yes ; Allow the user to compose and send a voicemail while inside
emailonly = no
emailsubject = You have a New Voicemail from ${VM_CALLERID}
emailbody = Dear ${VM_NAME} ,\n \t\t\t You have received a new voicemail from ${VM_CALLERID} \non ${VM_DATE}. \n Find attached.\n\n----\nAsterisk PBX
maxgreet =
maxsilence = 10
operator = no
maxmsg = 300
maxmessage = 300
minmessage =0
saycid = no
sayduration = no
envelope = no
review = no
moveheard = yes
maxlogins = 3

[zonemessages]
eastern=America/New_York|‘vm-received’ Q ‘digits/at’ IMp
central=America/Chicago|‘vm-received’ Q ‘digits/at’ IMp
central24=America/Chicago|‘vm-received’ q ‘digits/at’ H N 'hours’
military=Zulu|‘vm-received’ q ‘digits/at’ H N ‘hours’ 'phonetic/z_p’
european=Europe/Copenhagen|‘vm-received’ a d b ‘digits/at’ HM

[vmtech]

asterisk.localhost is clearly not a valid domain name.

1 Like

Thank you for the support, actually the issue was aliases.db was not updating even when restarted the server. have to manually update it using newaliases command

Now I’m reading stuff how to direct voicemail to email to aliases