Voicemail sending as asterisk@localdomain not as configured in voicemail.conf

My voicemails are being sent from "asterisk@localdomain even though my voicemail.conf is set to

serveremail=pbx@mydomain.com

My server is ubuntu 16.04 and hostname is “asterisk”. Where can I look to correct this?

This configuration need to be done on the MTA configuration file, what are you using to send emails

I send via postfix / sendmail. I think this was installed by default as part of the asterisk install? I have tried searching this on the internet and can find ways of changing the MTA from address but not a way allowing voicemail.conf determine the from address. This worked on the original install but the aws image was re-imaged following a puppet upgrade.

No MTA is installed by a normal Asterisk installation. I assume AsteriskNOW includes one, but MTAs require configuraiton.

I believe the configuration file you want is /etc/sendmail/main.cf. Google “how to configure sendmail ubuntu 16.04” and you’ll get the info you need :slight_smile: