Voicemail problem

i had configured voicemail, here is the config files voicemail.conf, sip.conf, extensions.conf, zaptel.conf, zapata.conf

voice mail is working when ever call is received, extension 2000 receives it and if not answered in 20 secs, message is stored in
voicemail no problem in that. after creating voice mail if some one again call at that no this time even bell dosent ring, busy
tone is heard, but when i restart machine call can be rceived in extension 2000, but as soon voicemail is created after 20 secs,
same problem than no one can call at that no,again gives busy tone.
###################################################################################

[root@localhost ~]# vi /etc/asterisk/voicemail.conf
[general]
format = wav
attach = yes

[default]
; Syntax for new entries looks like this:
; MailboxNumber => password,name,e-mail,pager,options
; (usually, the MailboxNumber is the same as the Extension)
2000 => 1234,abc,abc@abc.com
2001 => 1234,def,def@def.com

#############################################################################################

sip.conf

[general]
port = 5060
bindaddr = 0.0.0.0
context = others

[2000]
type=friend
context=voicemail
secret=1234
host=dynamic

[2001]
type=friend
context=voicemail
secret=1234
host=dynamic

#########################################################################################

vi /extensions.conf

[root@localhost ~]# vi /etc/asterisk/extensions.conf
[from-zaptel]; plz check zapata.conf
exten => s,1,wait(2)
exten => s,n,Goto(voicemail,2000,1)

[voicemail]
exten => 2000,1,Dial(SIP/2000,20)
exten => 2000,2,VoiceMail(2000,u)

exten => 2999,1,VoiceMailMain(${CALLERID(num)},s)

#########################################################################################

vi zaptel.conf

#autogenerated by /usr/sbin/wancfg_zaptel do not hand edit
#autogenrated on 2010-02-09
#Zaptel Channels Configurations
#For detailed Zaptel options, view /etc/zaptel.conf.bak
loadzone=us
defaultzone=us

#Sangoma USB U100 [bus:2-3 span:1]
fxsks=1
fxsks=2

###########################################################################################

vi zapata.conf

;autogenerated by /usr/sbin/wancfg_zaptel do not hand edit
;autogenrated on 2010-02-09
;Zaptel Channels Configurations
;For detailed Zaptel options, view /etc/asterisk/zapata.conf.bak

[trunkgroups]

[channels]
context=default
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
relaxdtmf=yes
rxgain=0.0
txgain=0.0
group=1
callgroup=1
pickupgroup=1
immediate=no

;Sangoma AU100 [slot:0 bus: span:1]
context=from-zaptel
group=0
signalling = fxs_ks
channel => 1

context=from-zaptel
group=0
signalling = fxs_ks
channel => 2

#########################################################################################

Hi

It sounds like you dont have disconnect signals enabled on your line.

You will find that the line will be freed up if you just unplug the line and plug it back in.

You need to speak to your PTO

Ian

yes u r absolutely right, i have to take out my PSTN line from fxo card n than when i plug it again start receiving call. how to solve this signal problem n whats PTO.

Ask them to enable positive disconnect signals
Ian

ask them whom, u mean to say i should say to my telecom company .

call is completed even than cli shows one active call

localhost*CLI> core show channels
Channel Location State Application(Data)
Zap/1-1 2000@voicemail:2 Up VoiceMail(2000|u)
1 active channel
1 active call

thx

now i am on centos 5.4, and configrured asterisk using these tar

asterisk 1.6.2.2.tar.gz
dahdi-linux-complete-2.2.1+2.2.1.tar.gz
libpri-1.4.10.2.tar.gz

if i configure normal dial plan i.e call comes and received by exten 2000 it gets received and disiconnect properly.when again some 1 calls no problem in receiving that call, here is the extension and core show channels

vi /etc/asterisk/extensions.conf

[from-zaptel]
exten => s,1,wait(2)
exten => 2000,1,Dial(SIP/2000,20)
exten => 2000,n,hangup()
##################################################################################
localhost*CLI> core show channels
Channel Location State Application(Data)
0 active channels
0 active calls
6 calls processed
#################################################################################

this dial plan is of voicemail when ever call is received in extension 2000, after 20 it goes to voicemail, n when user disconnects the call the signal is not getting terminated.so next time when some calls it says line is busy. here is extension.conf for voicemail and core show channels

extensions.conf

[from-zaptel]
exten => s,1,wait(2)
exten => s,n,Goto(voicemail,2000,1)

[voicemail]
exten => 2000,1,Dial(SIP/2000,20)
exten => 2000,2,VoiceMail(2000,u)
exten => 2999,1,VoiceMailMain(${CALLERID(num)},s)

#####################################################################################

localhost*CLI> core show channels
Channel Location State Application(Data)
DAHDI/1-1 2000@voicemail:2 Up VoiceMail(2000,u)
1 active channel
1 active call
4 calls processed

#################################################################################

                                                      IMPORTANT THING

when a call is received n if it goes to voicemail n get terminated by pressing pound key than no problem, with the line, line gets free again can receive the call.

but when a call is received and send to voicemail and terminated by disconnecting (without pressing the pound key) call gets end but channel is always showing active,so line is busy.

so now i think there is no signal problem only problem is with the dialplan.

Hi the proplem is what Ive previously said, This knowledge is based on 20 years experiance of voicemail and pbx deployments. you have to speak to your PTO and ask for a “positive disconnect signal” or sometimes called “CPC” signal enabled on the line. You can test this by putting a meter across the line and looking for the voltage drop when the call disconnects.

Ian

PTO is Public Telephone Operator, i.e .the organisation that provides your PSTN phone lines.