Verbosity doesn´t work

I’m trying to connect to my asterisk using “asterisk -vvvr”, setting verbosity to level 3.
But it doesn´t work. When I type “core show settings” it shows me “Verbosity: 0”.
Then I have to set manually “core set verbose 3” to work.

Thanks in advance.

This is not a support forum.

-vvvv only works on Asterisk process itself, not on remote console clients (the -r option).

Yes, verbose mode (-vvv) work with remote option (-r).
See my other server that is not having the problem I reported:

root@ubuntu:~# asterisk -vvvr
Asterisk 1.8.32.3, Copyright © 1999 - 2013 Digium, Inc. and others.
Created by Mark Spencer markster@digium.com
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

Connected to Asterisk 1.8.32.3 currently running on ubuntu (pid = 2664)
Verbosity was 0 and is now 3
ubuntu*CLI>