Using TLS with AMI

Hello all,

I have been successful in adding this information into manager.conf

tlsenable = yes
tlsbindport = 5039
tlsbindaddr =
tlscertfile = /var/lib/asterisk/keys/xxxx.pem
tlsprivatekey = /var/lib/asterisk/keys/xxxxx.pem

Now I need to know if there are any other steps to enable it and/or how to test it to be sure it’s working. I used Blink to test the Sip over TLS

Any helpful tidbits would be appreciated.


Straight from the sample config file:

; Parameters that control AMI over TLS. ("enabled" must be set too).
; You can open a connection to this socket with e.g.
;       openssl s_client -connect my_host:5039