Using SILK softphones with ConfBridge

Hello I want to hold wideband voice conferences to be broadcast.

I use Bria on my iPhones and MicroSIP on my Windows PC’s.

They dial an extension which goes to the new ConfBridge, this works perfectly on G722.

But when I use any SILK codecs I get this error constantly (thousands of times a minute)

   > lintosilk_frameout: encoding 480 samples
   > lintosilk_frameout: encoding 480 samples
   > lintosilk_frameout: encoding 480 samples
   > lintosilk_frameout: encoding 480 samples
   > lintosilk_frameout: encoding 480 samples
   > lintosilk_frameout: encoding 480 samples

Also the audio is crackly like it’s dropping packets.

Can anyone tell me why this is happening for SILK in a conference but G722 is working fine?

It happens if I use the iPhone or PC (no difference)

Thanks very much in advance.

No clue. The SILK support in app_confbridge and in Asterisk, in general, predates the SILK support in Bria.

Hello,

I’m having the same issue. I downloaded the codec_silk-11.0_1.0.0-pentium4m_32.tar.gz from http://downloads.digium.com/pub/telephony/codec_silk/asterisk-11.0/x86-32/ . This tar only include the .so file with no code.

It could be the case that the code have a “printf” for “lintosilk_frameout: encoding X samples” that has been left from a previos debug session from the coder?

I’m doing transcoding from silk to g711, and in every case i got that message. I triyed with silk8, silk12 and silk16.

Where can i get the exact code that was used to compile the .so ??

Thanks in advance