Using Cepstral SSML markup with app_swift

Running asterisk 1.4.17 and app_swift-2.0rc1. Working well.

I want to use Cepstral SSML markup (documented here: … &type=ssml ) in phrases in the dial plan, but cannot get it to work (yet). In other words, this:

works as expected from a shell prompt causing emphasis on the word “alert”. But this:

exten => s,n,Swift(This is an <emphasis level='moderate'> alert</emphasis> from)
does not. The CLI shows

but I never hear the word “alert” or any words after “alert” in that string, but I do hear the next words from the subsequent swift call in the next dialplan entry.

I tried surround putting double quotes outnd the markup delimeters with no result. FIgured it was time to ask if this will work at all and if so, how to delimit.

(Edited to correct incorrect closure of tag in original post. Thanks. Problem remains.)

exten => s,n,Swift(This is an alert from)

should be:

exten => s,n,Swift(This is an alert from)

i.e. the tag needs clsoing …

Argggh. Thanks for catching my typo in the post.

Changing to a correct closure of the tag yields the result I originally was attempting to describe.

exten => s,n,Swift(This is an <emphasis level='moderate'>alert</emphasis> from)

allows only the words “This is an” to be heard. So the syntax is still not right, or the app_swift is not passing it on as desired.

I found the answer over on Cepstral’s forums on this page:

The correct syntax is:

exten => s,n,Swift('This is an <emphasis level="moderate"> alert </emphasis> from')

You have to enclose the entire string in single quotes and substitute double quotes for single quotes in the SSML tag.