Using ARI with Nginx

I built the Asterisk 14.4 in Docker which is also working with Nginx.
Normal SIP traffic is working fine. It listens port 8088 for ARI service.
I tested with http:IP:8088/ari/xxxxx and it works however when I use http://domain:8088/ari/xxxxx and it’s fail.

Checked it doesn’t reach Asterisk while checking console log “ari set debug all on”
Wondering if any of you experience same issue and any solution. Thank you

Have you checked the DNS for the domain to make sure it resolves to where you would expect?

DNS should be working as I’m also using domain for our roaming SIP users.

and yes, I could find some packets hitting Asterisk server

You’ll have to be more specific. You stated originally that you don’t see packets when doing “ari set debug all on”. Are you referring to SIP messages? If so have you checked firewalls?

when I do tcpdump, I can see some packets, but it’s not showing in Asterisk console “ari set debug all on”
It only happens when I try http://domain:8088/ari/xxxxx
When I tried, http://IP:8088/ari/xxxxx, i can see packets and also log in Asterisk console “ari set debug all on”.

Wondering it’s related to Nginx, is there any guide by setting up the Nginx rule for ARI?

I don’t know of any documentation for that specific scenario. Have you looked at the nginx logs?

No related log found in Nginx.

Removed expose port 8088 from Nginx and make Asterisk as host network mode in docker compose.
Only 1 of my 5 servers works. Will compare the network configuration one by one.

My client issue…Tested on other device and it’s all good.