Unable to make calls,problem in extensions.conf - a2billing

As a part of my plan to implement calling card platform (a2billing),I had installed 2 TDM FXO 2406B cards and installed asterisk,zaptel,libpri - 1.4 versions.
where as BOARD1 will be outgoing lines 24 channels and Board 2 Incoming lines 24 channels.

Configuration details :

zapata.conf (apart from default configuration) – 1) signalling=fxs_ks,

;General Options

;; FXO Modules

;; FXO Module II

zaptel.conf - except default configuration
i had added " fxs_ks=1-24"incoming , fxs_ks=25-48 (Board 2)outgoing.when i made test call at first it was re-directed to “demo-instruction” default zaptel prompt of asterisk and even it is routing to IAX server of digium.

but when i add a2billing extension as following at extensions.conf other than what ever default is there;

; CallingCard application
exten => _X.,1,Answer
exten => _X.,2,Wait,2
exten => _X.,3,DeadAGI,a2billing.php
exten => _X.,4,Wait,2
exten => _X.,5,Hangup

then i had removed the ‘s’ extension configuration that is routing call default to the “demo-instruct” of asterisk,
then when i dial it says invalid extension.

Pls help me out on this how to route incomings calls to board designated for out going.

latest log on asterisk i found :

Asterisk Ready.
*CLI> – Starting simple switch on ‘Zap/1-1’
[Mar 14 12:15:53] ERROR[3262]: callerid.c:564 callerid_feed: fsk_serie made myle n < 0 (-1)
[Mar 14 12:15:53] WARNING[3262]: chan_zap.c:6416 ss_thread: CallerID feed failed : Success
[Mar 14 12:15:53] WARNING[3262]: chan_zap.c:6516 ss_thread: CallerID returned wi th error on channel ‘Zap/1-1’
== Starting Zap/1-1 at incoming,s,1 failed so falling back to exten ‘s’
== Starting Zap/1-1 at incoming,s,1 still failed so falling back to context ‘d efault’
– Executing [s@default:1] Wait(“Zap/1-1”, “1”) in new stack
– Executing [s@default:2] Answer(“Zap/1-1”, “”) in new stack
– Executing [s@default:3] Set(“Zap/1-1”, “TIMEOUT(digit)=5”) in new stack
– Digit timeout set to 5
– Executing [s@default:4] Set(“Zap/1-1”, “TIMEOUT(response)=10”) in new sta ck
– Response timeout set to 10
– Executing [s@default:5] BackGround(“Zap/1-1”, “demo-congrats”) in new sta ck
– <Zap/1-1> Playing ‘demo-congrats’ (language ‘en’)
– Invalid extension ‘57’ in context ‘default’ on Zap/1-1
== CDR updated on Zap/1-1
– Executing [i@default:1] Playback(“Zap/1-1”, “invalid”) in new stack
– <Zap/1-1> Playing ‘invalid’ (language ‘en’)
== Auto fallthrough, channel ‘Zap/1-1’ status is ‘UNKNOWN’
– Hungup ‘Zap/1-1’

You need to read the a2biiling docs and then, if not enough, search in the a2billing forum, I’m quite sure there you’ll find the solution.


Marco Bruni

Now im able to do incoming calls,can you tell how to route the calls through TDM2406B card Board 2 as mentioned above.

A2billing says number is unavailable but where as number is active when i try from my mobile phone.

do i need to specify what channel should route out going any way i had determined 2 FXO modules 1-24 as incoming and 25-28 as out going but still call couldn’t go thru.

Pls help me out on this.

can you pls let me know how and where do i need outgoing to configure trunk with zap channel 25-48 in asterisk.

because A2BILLING uses the trunk with same name what we had created in asterisk,but some how when i tryed on GUI asterisk 1.4,it is unable to identify the analog TDM 2406B cards installed,only digital cards option displayed.

Pls let me know on this,this could resolve my entire issue.

Thanks Regards

Hi Bruni,

Thanks alot for your suggestion. I had resolved most of issues on a2billing and now even incoming call is thru but still got hang up with other problem like out going.

Pls find the below log when i dial from using a2billing platform,im getting the following errors on zap channel. it seems asterisk is not identifying the call sent from a2billing.

error log : where 9011 is prefix im firing call from a2billing.

chan_zap.c:7783 zt_request: Unable to determine group for data group1/901100971509344082
– Limit Data for this call:WARNING[4004]: app_dial.c:1196 dial_exec_full:

timelimit = 60000
play_warning = 31000
play_to_caller = yes
play_to_callee = no
warning_freq = 30000
start_sound = (null)
warning_sound = timeleft
end_sound = (null)

[Mar 14 23:48:32] WARNING[4004]: chan_zap.c:7783 zt_request: Unable to determine group for data group1/901100971509344082

callsrvr*CLI> Unable to create channel of type ‘ZAP’ (cause 0 - Unknown)

[Mar 14 23:48:32] WARNING[4004]: app_dial.c:1196 dial_exec_full: Unable to create channel of type ‘ZAP’ (cause 0 - Unknown)

== Everyone is busy/congested at this time (1:0/0/1)

== Everyone is busy/congested at this time (1:0/0/1)

callsrvr*CLI> a2billing.php: file:Class.RateEngine.php - line:1079 - [K=0]:[ANSWEREDTIME=0-DIALSTATUS=CHANUNAVAIL]

a2billing.php: file:Class.RateEngine.php - line:1079 - [K=0]:[ANSWEREDTIME=0-DIALSTATUS=CHANUNAVAIL]

callsrvr*CLI> a2billing.php: file:Class.RateEngine.php - line:1119 - FAILOVER app_callingcard: Dialing ‘ZAP/group1/901100971509344082|60|HRgrL(60000:61000:30000)’ with timeout of ‘60’.

a2billing.php: file:Class.RateEngine.php - line:1119 - FAILOVER app_callingcard: Dialing ‘ZAP/group1/901100971509344082|60|HRgrL(60000:61000:30000)’ with timeout of ‘60’.

callsrvr*CLI> a2billing.php:
Do i need to create any extension for out going also if yes, i would request you to please provide me format.Im using group 1 for out going calls of which is 24 channels. Pls let me know what to do next.