Unable to Connect Calls Using PJSIP

I am in the process of building a new configuration of Asterisk using PJSIP. I am able to register SIP users but cannot place calls from one user to another.

From the Asterisk CLI, I see the following errors when trying to connect a call:

[quote]-- Executing [1000@default:1] Dial(“PJSIP/1001-00000000”, “PJSIP/1000/sip:1000@172.21.11.0:40729;transport=TCP;rinstance=81e1ff93df94a85a&PJSIP/1000/sip:1000@172.21.11.0:51659;transport=TCP;rinstance=a6ed2c491640e128&PJSIP/1000/sip:1000@172.21.11.0:52918;transport=TCP;rinstance=19f861d6c828d4be”) in new stack
– Called PJSIP/1000/sip:1000@172.21.11.0:40729;transport=TCP;rinstance=81e1ff93df94a85a
– Called PJSIP/1000/sip:1000@172.21.11.0:51659;transport=TCP;rinstance=a6ed2c491640e128
– Called PJSIP/1000/sip:1000@172.21.11.0:52918;transport=TCP;rinstance=19f861d6c828d4be
– PJSIP/1000-00000003 connected line has changed. Saving it until answer for PJSIP/1001-00000000
– PJSIP/1000-00000001 connected line has changed. Saving it until answer for PJSIP/1001-00000000
– PJSIP/1000-00000002 connected line has changed. Saving it until answer for PJSIP/1001-00000000
[Apr 1 16:20:06] ERROR[10661]: pjsip:0 <?>: tcpc0x273e448 TCP connect() error: Connection refused [code=120111]
[Apr 1 16:20:06] WARNING[10661]: pjsip:0 <?>: tsx0x273dcb8 Failed to send Request msg INVITE/cseq=2512 (tdta0x2685370)! err=120111 (Connection refused)
[Apr 1 16:20:06] ERROR[10661]: pjsip:0 <?>: tcpc0x2430d98 TCP connect() error: Connection refused [code=120111]
[Apr 1 16:20:06] WARNING[10661]: pjsip:0 <?>: tsx0x242eb28 Failed to send Request msg INVITE/cseq=23778 (tdta0x242cac0)! err=120111 (Connection refused)
[Apr 1 16:20:06] ERROR[10661]: pjsip:0 <?>: tcpc0x23b37a8 TCP connect() error: Connection refused [code=120111]
[Apr 1 16:20:06] WARNING[10661]: pjsip:0 <?>: tsx0x2436978 Failed to send Request msg INVITE/cseq=1127 (tdta0x26dbbe0)! err=120111 (Connection refused)
== Everyone is busy/congested at this time (3:0/3/0)
– Auto fallthrough, channel ‘PJSIP/1001-00000000’ status is ‘CONGESTION’[/quote]

The transport method is set to TCP. Here is my config from pjsip_wizard.conf:

[quote][1000]
type = wizard
accepts_auth = yes
accepts_registrations = yes
has_phoneprov = yes
transport = transport-tcp
inbound_auth/username = 1000
inbound_auth/password = secret
endpoint/allow = ulaw
endpoint/context = default
aor/max_contacts = 15
[/quote]

Here is the transport section of the configuration from pjsip.conf:

[quote][transport-tcp]
type=transport
protocol=tcp
bind=0.0.0.0
[/quote]

I can provide additional logs/configs if it would be useful. Any help would be appreciated.

Thank you!

Josh