Un-registered user still present in "sip show peers"


We’re having a problem, that when a user sends un-REGISTER (i.e. REGISTER with Expire: 0 header), and we see a "Unregistered SIP user " in CLI, it still (sometimes) is present in “sip show peers” and asterisk actually tries to pass calls on it

we suspect with a 90 % certainty that this is due to “rtcachefriends=yes”

we’re using dynamic realtime friends config
(extract from extconfig.conf:
sipusers = odbc,MySQL-Asterisk,sip_friends
sippeers = odbc,MySQL-Asterisk,sip_friends

Asterisk 13.1.0, Asterisk 13.2.0

Is this expected behaviour, misconfiguration, or a bug ?

Thanks a lot !

… any chances to get a reply here ? Or should I post a bug on this on issues.asterisk.org ?

1.Did you tried reloading chan_sip.so (using module reload chan_sip.so) once.
2. how is you sip extensions registering to asterisk ,are they from same network (local LAN) connecting via internet etc…
3.did you tried adding qualify=yes .

Arun kumar Koodalingam

Hi Arun

  1. This is persistent behaviour, occurring for a large periods of time already - we have restarted Asterisk many times, and installed different versions of it (without changing config) - 13.1.0, 13.2.0, 13.3.2 - this issue seems like to be present on all of them
    I wonder if it’s not a “known issue” with realtime SIP config ?

  2. The peers are on global network, not from LAN

  3. “qualify” setting is “null” for our peers in peers database, and is not set globally in a realtime “sip.conf”

Should we try it ?

Thanks !