Trunk keeps sending calls

My trunk;

[trunk]
type=peer
insecure=invite
qualify=yes
port=5060
dtmfmode=rfc2833
allow=all
context=home
canreinvite=no
canredirect=no
callcounter=yes
host=x
username=y
secret=x

I have a queue, my queue.conf file;

[outside]
timeout = 40
member => Local/1@xxx
autofill=no
ringinuse=no

My extensions.conf file;

[xxx]
        exten => 1,1,NoOp(call for call center)
                same => n,Dial(SIP/trunk/xxx,,tTgG(msg,1))

        exten => msg,1,Goto(anum,1)
        exten => msg,2,Goto(cnum,1)
        
        exten => anum,1,NoOp("caller")

        exten => cnum,1,Playback(hello)
        exten => cnum,n,Set(CHANNEL(hangup_handler_wipe)=call-center,csh,1(args))
        exten => cnum,n,WaitExten(100)
        exten => cnum,n,NoOp(dial hangup)

        exten => csh,1,Verbose(0)
                same => n,System(/usr/bin/python3 /etc/asterisk/ari-test.py ${ORIGCHANNEL})
                same => n,Return()

        exten => #,1,NoOp(press #)
                same => n,Bridge(${ORIGCHANNEL})

        exten => 9,1,Hangup()
                same => n,Hangup()

When a user enters queue, I want them to call a number. When the called person picks up the phone, I play a message to him and if he presses the # key, I bridge it with the caller. If he presses the 9 key or rejects the call without picking up, I want to redial until the connection is established by pressing the # key. The caller also has to wait in the queue until the connection is established. But when the called person picks up the phone and starts listening to the message, after 5 seconds, queue sends a call to the same person again, enters an endless loop and sends calls continuously. How can i solve this problem. Thanks for your answers.

My output;

-- Called Local/1@xxx
    -- Executing [1@xxx:1] NoOp("Local/1@xxx-00000000;2", "call for call center") in new stack
    -- Executing [1@xxx:2] Dial("Local/1@xxx-00000000;2", "SIP/trunk/yyy,,tTgG(msg,1)") in new stack
  == Using SIP RTP CoS mark 5
    -- Called SIP/trunk/05456573078
       > 0x7ff9ec034cc0 -- Strict RTP learning after remote address set to: x:19914
    -- SIP/trunk-00000003 is making progress passing it to Local/1@xxx-00000000;2
    -- SIP/trunk-00000003 answered Local/1@xxx-00000000;2
    -- Executing [msg@xxx:1] Goto("Local/1@xxx-00000000;2", "anum,1") in new stack
    -- Goto (xxx,anum,1)
    -- Executing [anum@xxx:2] NoOp("Local/1@xxx-00000000;2", "caller") in new stack
    -- Auto fallthrough, channel 'Local/1@xxx-00000000;2' status is 'ANSWER'
    -- Nobody picked up in 7000 ms
    # After responding local/1@xxx it runs the same loop again saying nobody picked up #
    -- Executing [msg@xxx:2] Goto("SIP/trunk-00000003", "cnum,1") in new stack
    -- Goto (xxx,cnum,1)
    -- Executing [cnum@xxx:1] Playback("SIP/trunk-00000003", "hello") in new stack
    -- <SIP/trunk-00000003> Playing 'hello.gsm' (language 'en')
       > 0x7ff9ec034cc0 -- Strict RTP switching to RTP target address x:19914 as source
    -- Executing [cnum@xxx:2] Set("SIP/trunk-00000003", "CHANNEL(hangup_handler_wipe)=xxx,csh,1(args)") in new stack
    -- Executing [cnum@xxx:3] WaitExten("SIP/trunk-00000003", "100") in new stack
       > 0x7ff9ec034cc0 -- Strict RTP learning complete - Locking on source address x:19914
    -- Called Local/1@xxx
    -- Executing [1@xxx:1] NoOp("Local/1@xxx-00000001;2", "call for call center") in new stack
    -- Executing [1@xxx:2] Dial("Local/1@xxx-00000001;2", "SIP/trunk/yyy,,tTgG(msg,1)") in new stack

I solved the problem like this;
In queues.conf;

member => Local/1@xxx,1,Test,SIP/trunk

After giving SIP/trunk as status interface, the problem was solved. If you have a different suggestion, I’d be happy to hear it.