Trixbox/Extension Busy question

I had tested calling extensions (Grandstream GXP2000s) a few months ago with a plain jane installation of Asterisk. At that time, if somebody was on Extension B and another person picks up the phone at Extension A and dials Extension B, one of the 3 remaining extension buttons would light up on the phone and allow the person at Extension A to switch to the incoming call.

But now, using Trixbox, if the same thing happens, Extension A simply receives a busy signal (or gets sent immediately to voicemail).

Is this a call waiting issue? Is there a way to enable this by default instead of per line?


Well, I got this one fixed also. I didn’t realize that on the GXP-2000 series phones that you had to disable Local Call Features on the phone, otherwise when you dial *70 to enable call waiting, it only enables it locally on the phone, not in TrixBox/Asterisk.

I also found this:

"By default FreePBX creates new extensions with “call waiting” disabled, meaning when you are on the phone a second call will get a busy message and get sent immediately to voicemail. If you wish the option for your handset to beep and display on your LCD the second inbound call giving you the option to answer it or ignore it, then you need to dial *70 on each handset -OR- change the default for new extensions created …

  1. Click, “System Administration” then “Config Edit”

  2. Click, “/etc” at the top/middle then “amportal.conf”

  3. Scroll down in the window until you find “ENABLECW=no”, change it to “yes”

  4. Click, “update” button at the bottom"

Which is very helpful if adding a lot of extensions.