Transfer and VoiceMailMain conflict

I am having a small problem. I have transfer active on my calls, enabled by features.conf and adding “tT” to my dial commands. I am using a call file to generate an outbound call to my cellphone when I receive a voicemail. The callback goes to the following extension in my dialplan:

context callback {
    s => {
        if (${cmd}=1) {

The vm-listentomessages lets me know I have a message and offers me a chance to press one to listen. I am using VoicemailMain, because I want this to work for several different people. The problem is that when I press the ‘#’ key entering my mailbox number, I am prompted for the transfer extension. Any suggestions?


Russell Markus


In features.conf change it to something else like ## or use the transfer button on the handset (if you have one).

blindxfer => ## ; Blind transfer (default is #)
;disconnect => *0 ; Disconnect (default is *)
;automon => *1 ; One Touch Record a.k.a. Touch Monitor
;atxfer => *2 ; Attended transfer
;parkcall => #72 ; Park call (one step parking)


Thanks for the reply. I have changed it in features.conf to *. I was hoping there was a way to turn off the call transfer feature via a dialplan command. This will work, but if anyone has further insight I am always willing to learn.