Temporary failure in name resolution

I have an Asterisk server that I am trying to get set up with flowroute. I am able to get it to register and make incoming calls just fine. However, when I try to call out I am getting the message

 netsock2.c:303 ast_sockaddr_resolve: getaddrinfo("flowroute", "(null)", ...): Temporary failure in name resolution

I am following flowroute’s instructions from here

The place where I believe the problem is in extensions.conf at the outgoing context section

[outgoing]
exten => _1NXXNXXXXXX,1,Dial(SIP/${TECHPREFIX}${EXTEN}@flowroute)
exten => _NXXNXXXXXX,1,Dial(SIP/${TECHPREFIX}1${EXTEN}@flowroute)
exten => _NXXXXXX,1,Dial(SIP/${TECHPREFIX}1${AREACODE}${EXTEN}@flowroute)
exten => _011.,1,Dial(SIP/${TECHPREFIX}${EXTEN:3}@flowroute)

I have done a good bit of research on this issue, and it seems to be either DNS or a SIP issue from what I can tell (I am pretty new to this). My server(ubuntu 18.04) is able to resolve flowroute’s IP from the CLI with no issues.

What would be a good next step in debugging this? Is there a good way to test if this is DNS or something else? Any advice would be appreciated, this is all pretty new to me and I feel a bit over my head trying to get this set up

How is your DNS finding out the full domain name for flowroute?

Sorry not totally sure what you mean, I am able to resolve flowroute.com and sip.flowroute.com with an nslookup command

But Asterisk was trying to resolve flowroute, not flowroute.com.

Web browsers might try appending .com and prefixing with (in their case) www., but that is a special case.

That was the default from Flowroute’s documentation, I changed it to us-west-or.sip.flowroute.com and am still getting the same error

I use Flowroute for outbound. My dial command looks like:

        exten = _1nxxnxxxxxx,5,         dial(sip/${TECHPREFIX}*${EXTEN}@flowroute,30,gr)

And the section in sip.conf:

[flowroute]
        canreinvite                     = no
        context                         = inbound
        dtmfmode                        = rfc2833
        fromdomain                      = us-west-or.sip.flowroute.com.
        host                            = us-west-or.sip.flowroute.com.
        insecure                        = port,invite
        qualify                         = no
        secret                          = xxxxxxxxxxx
        srvlookup                       = no
        type                            = friend
        username                        = xxxxxxxx

which is probably a bit of dead-wood, but it works for me.

Okay, that seemed to do the trick. I think the thing I was missing was a context named flowroute. Just got my first outbound “hello world” to work! May seem miniscule but that’s super exciting for me. Thanks so much! Now to dive into the dialplan…

If you are referring to this:

I think this is better named as a section – extension means something else.

You may want to invest some effort in eliminating deadwood from my snippet – no need to propagate my laziness :slight_smile:

By dead wood do you mean redundant lines that are default? I’m just happy to have this working, but I should read the docs and figure out what all of these values mean

More like settings that are obsolete that I just copied from previous versions. Just see what you can eliminate and still have a working connection – and then tell me :slight_smile:

So should I…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.