TCP Support& Asterisk 1.8.3 registration error

Hello all,

Sorry for this question, but I’m newbie, and I wanted to enable connections for my users Over 3G under Android 2.2, where I used cSipSimple client.

The issue come from peers lagged, and inbound calls missing over 3G, so after suggestion from cSipSimple forum, I enable the server to handle tcp.

But, the client are failing to login, and in Asterisk Cli I see the following error:

In sip.conf I have the following:

tlsenable=yes
tlsbindaddr=0.0.0.0
tlscertfile=/etc/asterisk/keys/asterisk.pem
tlscafile=/etc/asterisk/keys/ca.crt
tlscipher=ALL
tlsclientmethod=tlsv1
transport=udp,tcp,tls
tcpbindaddr=0.0.0.0
bindaddr=0.0.0.0
bindport=5060
bindport=443

And into the peer configuration i add transport=tcp…

I tried the same for Twinkle Softphone, and I’m having the same error…

I guess i have some error in my tcp configuration, no, or it’s comming from the client?

Also i have

[quote]netstat -tlpn | grep 443
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 175/skypeforasteris[/quote]

Advice, please!

Thanks,

You also need tcpenable=yes in the general section of your sip.conf file.

Cheers.

[quote=“malcolmd”]You also need tcpenable=yes in the general section of your sip.conf file.

Cheers.[/quote]
Thanks malcolmd for you fast answer,

As i post, and I forget to mention the section, in general i have this:

[general]
tlsenable=yes
tlsbindaddr=0.0.0.0
tlscertfile=/etc/asterisk/keys/asterisk.pem
tlscafile=/etc/asterisk/keys/ca.crt
tlscipher=ALL
tlsclientmethod=tlsv1
transport=udp,tcp,tls
tcpbindaddr=0.0.0.0
bindaddr=0.0.0.0
bindport=5060
bindport=443

But when i enable that, I cannot login to any of my sip truncks, i guess it’s affecting all over the server as tls exclusivly…what wrong I have here?

Thanx,

Bindport isn’t an option.

If you want to enable TLS, UDP and TCP support, you’d need something like:

[general]
...
udpbindaddr=0.0.0.0:5060
tcpenable=yes
tcpbinaddr=0.0.0.0:5060
tlsenable=yes
tlsbindaddr=0.0.0.0:5061
tlscertfile=yourcertfile
tlscafile=yourcafile
tlscipher=ALL
tlsclientmethod=tlsv1
...

Then, the peer definition just needs to include the transport method, e.g.

[mypeer]
...
transport=tls,tcp,udp
...