TAPI working, but not in queues


#1

Hope someone can help me here as this is quite annoying.

I’m running Asterisk 1.8.2.3 (probably needs upgrading to latest version since 1.8.7.x is out now) and Need TAPI to work.
Now it works fine using 2 or 3 TAPI adaptors, but never when i answer a call from a Queue.

Iv’e tried: -

ASTAPI
Ingenious (my favourite)
and another one i can’t remember.

Now i got all three to work, but none of them worked when i picked up a call from a queue.

Is there any way of sending TAPI messages from the dialplan at all? Or has someone else not got this problem and can share their settings?

My Queue config is: -

musicclass = mohy
strategy = ringall
retry=3
timeoutrestart=yes
autofill=yes
timeout = 30
wrapuptime=0
announce-frequency = 0
announce-holdtime = no
setinterfacevar=yes
setqueueentryvar=yes
joinempty = yes
ringinuse = yes
monitor-format = gsm


#2

Try adding

eventwhencalled=yes

to your queues.conf .


#3

Didn’t work adding that in, but i did manage to get it working using different TAPI adaptors

Active doesn’t work that well in win 7, but Xtelsio seems to do the job, however i needed a proxy to service the 20 or so connections, which i found here: -

issues.asterisk.org/view.php?id=2506 (nice perl script running on Ubuntu server now for testing)

seems to be working nicely, although I have a feeling it all didn’t work to start with because of our helpdesk software…
i’ll post the solution when i find it