Supressing "rport" in sip register

I am trying to register my asterisk 1.4 with a sip server which does not like rport in headers. If the register request has “rport” attached it always responds with 400 Bad Request. I have verified the problem with an x-lite and packet dumps: when I turn off the rport in x-lite it works. If it is on, the server responds with 400. The rest of the registration packets is equal thus the problem must be the rport.

With nat=never I am able to get the asterisk to connect to the server as peer in a context. However, for the register statement in the general context I know of no way how to specify that “rport” should not be used in REGISTER. Is this possible?