Strange behavior with old modems

I’m implementing Asterisk in several callcenters for our office. Because I have a legacy to come over from the old setup, I have to bare with some old functionality to make calls. It is not possible to have everything set over to the new system, which works great with Asterisk, so I’d really like to get this working.

The problem is, that we have several phones, which are connected to modems. These modems send the dialrequest to the server, the server dials the number et voila, the agent is talking to a customer. Some of these modems work flawlessly. They produce calls every single time. But some others just randomly produce calls. Sometimes one out of seven, but sometimes one out of four times works.

The times it produces nothing, I see just “nothing” happening in Asterisk. Sure, I see the phone got picked up, and that it is hung up again, but nothing in between. Apparently the modems just do not reach Asterisk. To me it is strange, that sometimes these failing modems are able to produce calls. I can remember to have read something about the amount of ms that zaptel reacts to incoming requests. Can that have something to do with it? Does that mean I have to recompile the drivers and change those values somewhere? Or are there other settings I could try?

I’m really starting to get nervous about this problem, cause management is starting to expect results… Anyway, any help would be much, MUCH appreciated!

nobody? is my question unclear? if so, please say so, then i’ll try to rephrase it…

have several phones, which are connected to modems??

why is there a modem between the phone and asterisk is this some automated call setup and is this modem connected to a channelbank or something?

This is an automated call setup indeed. There is an old application, which allows the agent to push a button, which has the modem dial the number, so the agent does not have to punch it in himself. Each computer has it’s own modem/phone setup.

The modems are now connected directly to some samsung PBX. I however, make use of Astribanks, to which the modems connect directly as well. To automate the calling in the future, the modems can be removed from the setup, because the server will do all the dialing.

But, since it is not possible to have the whole callcenter move to the Asterisk based apps, i need some way to get the old setup to work…

i don’t think you can change the time that it takes the astribank to pickup and listen to numbers, but you can take a look at the old modems they should haven some option to wait for dialtone before producing the actual call also you an try to add some pause before the dial,that’s the best option i can think of

tnx, i’ll look into that. will get back with the results

well, that did not do the trick… i tried to send out a W (wait for dialtone) with the modems, but same results. Any other suggestions?

How many modems are we talking about that work/don’t-work?

Is this the setup:

<agent headset>-----<modem>------<analog port on phone system>

Are they internal/external modems?
Are they all the same type/brand ?
If you change a modem from a working computer to a non-working computer does the failing dial follow the modem or stay with the computer?

Can the application be re-written slightly to take advantage of asterisk?


about 90% of roughly 200 modems don’t work. Or at least: not all the time…
They are mostly the same type/brand, but not all.

I have not yet tried to switch computers, because the computers are also about 90% the same. And the working ones are the same as the not-working ones.

And yes, the application can be slightly modified. What do you suggest?

That is a really tough one…especially with 200 (that’s a big cost to add new handsets/headsets)…

What is plugging into what?
Are we talking about a headset jack or an analog phone jack?

re: making changes to the application, can you add a pause of one or two seconds before dialing the digits? OR, what modifications can you make?

It is a big cost indeed… That is why i’d like to see it fixed :smile:

Anyway, a phone is connected to a modem, the modem is connected to the machine and the server. It is an analog phone jack, which is plugged into the modem.

It actually is not MY application, it’s an oldskool clipper one written by my boss. He can change everything he’d like i guess. We already tried the W command at the modems (Wait for dailtone. Don’t ask… clipper stuff). Kinda flabbergasted about this problem… Especially cause it does not happen all the time. 99% of the attempts fail and 1% at the faulty modems works… I’d rather have never or always…