SPA-1000 Asterisk and Call waiting


I have everythng working on my * all the features that I want exept one.

I have a SPA-1000 connected to my home phones and X100P for the POTS line. The SPA gives me call waiting indication(beep) but when I press flash I just get dial tone. is it SPA-1000 thats doing something wrong or * not flashing the card ? Please help me with this issue because with out call waiting I cant use my * at all. Thank you.

No one knows about this issue ? When SPA-1000 sends a hook flash to * how does * know how to flash ? do I have to put something in my dial plan, sip config ?

Make sure you are allowing more than one incoming call in your sip.conf.

Not sure if this is the issue though because I am not 100% sure you would even get the tone if that was not configured right.

One thing we have noticed in the past is that using a different phone hooked up to the ATA does a better job. Sometimes the flash button on the phone is flakey.

Thanks for the reply

Well in the debug from the SPA-1000 I see that hook flash is being sent to the * but for the ZAP FXO card its not flashing the card. If I make a inter * call the call waiting works. I want it to send a flash to the zap card I guess.

I also tried to create custom app to use like *3 but this is what I get on the console


Jul 30 16:06:41 WARNING[3953]: app_flash.c:105 flash_exec: SIP/spa-1000-086e1000 is not a Zap channel[/code]

Which tells me that app_flash is looking at the current channel being used not the zap/1 like it supposed to. I looked thru the code and tried to modify it to use zap/1 but it looks like when it passes the *chan the aray already has the sip chanel and thats why its trying to flash the SIP channel is there anyway to modify app_flash.c to use the right zap/1 channel instead of the current channel ? Thanks in advance for any help ?

Ok here is somethign else maybe someone can help with, since I cant find anythign else on this issue…

Im trying to do the *3 method from here … md%20Flash

the problem is that the program app_flash is designed to flash the ZAP channel if I understand it, but for some reason it tries to flash the current channel that the command is coming from.

This is me using a custom app in functions.conf

zapflash => *3,caller,flash,()

and calling it using extensions.conf

exten => s,1,Set(DYNAMIC_FEATURES=zapflash)
exten => s,n,Dial(Sip/spa-1000,20,tw)

and this is the output that I get on the console when I press *3

WARNING[4238]: app_flash.c:105 flash_exec: SIP/spa-1000-09da4ce8 is not a Zap channel

Looking at the code of the function

flash_exec  (  struct ast_channel *  chan,  

 void *  data 

 )  [static] 

passes the *chan array which actually has the current channel not the Zap channel parameters. And I cant pass any parameters using Flash().

Is there anyway to change the function to pass parameters such as Zap/1 or just have the flash_exec always flash the Zap/1 channel and nothing else ?

I really appreciate any help. Thank you in advance.