[SOLVED] - unexplained timeout on iax2 register


#1

I have several asterisk boxes with dynamic IPs.

In order to register them with eachother they each have an account with a dynamic-ip-to-dns service. The gatways on the respective network keep the domain name pointing to the right IP.

For some reason, sometimes even when trying to register with the correct IP, the logins timeout.

Check out my CLI outputs and Configs below:

REGISTERING BOX CLI OUTPUT
filomena*CLI> iax2 show registry
Host                          Username         Perceived           Refresh  State
56.127.235.8:4569     Filomena    56.153.137.9:4569      60  Registered
56.197.169.184:4569   Filomena    <Unregistered>         60  Request Sent
56.111.13.159:4569    Filomena    56.153.137.9:4569      60  Registered

REISTERING BOX CONFIGS - iax.conf

register => Filomena:secret@bmy.dyntodns.com

HOST BOX CONFIGS - iax.conf

[Filomena]
type=friend
context=fromwork
secret=secret
host=dynamic

All together I have four boxes logging into eachother using this method. This is the only one timing out. In other words, these same boxes are registering other boxes which are in turn registering with the two of them. For whatever reason, this one times out.

Thanks in advance.

UPDATE: I just noticed something I think might be related.

The host box is also registering with the timing out box, and I notice it is being perceived on a random port (1030), for whatever reason. Could this be related?
HOST BOX CLI OUTPUT

Host                  Username                 Perceived              Refresh  State
56.127.235.8:4569     be          56.197.169.184:4569        60  Registered
56.111.13.159:4569    be          56.197.169.184:4569        60  Registered
56.153.137.9:4569     be          56.197.169.184:1030***     60  Registered

UPDTE II

I notice that for a few minutes at least Filomena registers to Be. Then it flakes out and stays that way 90% of the time.

I could use ethereal to see whats going on, but i wouldnt know what to look for. Any suggestions?


#2

[bump] Not Solved [/bump]


#3

i didnt make the sample docs between 1.0.X and 1.2 so i wasnt using dnsmanager.conf

that was easy