[SOLVED]Transfering PSTN call back to OBi110 handset / analogue phone

I have a new OBi110 with updated firmware to 1.3.0 (Build: 2886). I’m in the UK.
I have a Raspberry Pi Zero with RasPBX with Asterisk 13.13.1 upgraded to 13.15.0 & FreePBX upgraded to

I am not using OBiTalk or any SIP provider and I have no SIP hardphones at the moment.

I followed this webpage https://liquidstate.net/blocking-silent-and-nuisance-calls-with-an-obi110-raspbx-asterisk-pbx/ All that works.

I’ve successfully:

  1. called internal softphone to softphone
  2. called from a softphone to my mobile via the OBi110
  3. called from my mobile to my PSTN line and then to a softphone (Dial Plan temporarily transferred all incoming calls to the softphone)

I’m now trying PSTN Inbound call -> OBi110 Line -> SP2 -> Asterisk -> Dial Plan Filter -> Asterisk -> SP1 -> OBi110 Analogue Phone.

It fails at transferring back via SP1 with Log error (see below)

Using FreePBX my trunk out is defined as:

Name: OBiTrunkSP1
Outbound CallerID: land line no
Sip Settings: Outgoing
Trunk Name: OBiTrunkSP1
Peer Detail:
username=land line no
type=friend also tried peer
Sip Settings: Incoming - all blank

and an outbound route:

Route Name: Handset
Trunk Sequence for Matched Routes: OBiTrunkSP1
Dial Pattern / Match: XX.

And the Dial Plan code is (extract):


exten => _X.,n,Log(NOTICE, Known Caller ${CALLERID(all)})
exten => _X.,n,Dial(SIP/OBiTrunkSP1/${EXTEN},60)
exten => _X.,n,Hangup()
… nothing…


Ext. land line no.: Known Caller “” mobile no.
pbx.c: Executing [land line no@from-house-pstn:3] Dial(“SIP/OBiTrunkSP2-0000000a”, “SIP/OBiTrunkSP1/land line no,60”) in new stack
app_dial.c: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)
app_dial.c: Everyone is busy/congested at this time (1:0/0/1)
pbx.c: Executing [land line no.@from-house-pstn:4] Hangup(“SIP/OBiTrunkSP2-0000000a”, “”) in new stack
pbx.c: Spawn extension (from-house-pstn, land line no., 4) exited non-zero on ‘SIP/OBiTrunkSP2-0000000a’

Despite the Hangup, the PSTN phones keep ringing. Note the Analogue phone connected to the OBi110 does not ring at any point and if I pick it up while the PSTN phones are ringing I get a dial tone.

The OBi110 is configured:

Voice Services / SP1 is defined with:
X_ServProvProfile: A (default)
X_InboundCallRoute: ph (default)
MaxSessions 5
MWIEnable ticked
X_VMWIEnable ticked
MessageWaiting unticked
AuthUserName land line no.
URI land line no.@ip no. of Asterisk/RaspPi

I also tried land line no.@ip no. of OBi110

ITSP Profile A SIP is defined with:
ProxyServer ip no. of askerisk/RaspPi
X_SpoofCallerID ticked
X_UseRefer ticked
X-AccessList ip no. of askerisk/RaspPi

OBiTalk Provisioning is disabled.

Thank you for reading. Help is appreciated.


This is not Asterisk. You will need to ask this on a forum that understands this language ( http//community.freepbx.org/ ???)

OBTrunkSP1 either hasn’t registered or isn’t even rejecting the OPTIONs sent as a result of qualify=yes.

type=peer is preferred and canreinvite is deprecated or obsolete.

Despite the Hangup, the PSTN phones keep ringing.

Analogue lines have no way of signalling that an unanswered call has failed. A loop will never have been applied to the line, so cannot be removed to indicate the end of the call. If you want rich signalling, you need to use ISDN, either directly, or via an ITSP.

Thanks David for a quick reply.

I looked for registration errors in the log but could see nothing of note. I then started looking at the OBi110 status screens and noted that both SIP1 and SIP2 were using the same port. Given these are both using the same Asterisk system I started looking at changing one.

That led me to look at the sip_additional.conf file. There I saw that when following the set up at https://liquidstate.net/ I had defined an extension with an id of my land line number and a callerid=Analogue Phone <_land_line_no>

So I thought I would change the Dial Plan to call this extension:
exten => _X.,n,Dial(SIP/_land_line_no,60)

It works! Now the handset rings (and the PSTN phones continue to ring). Picking up the handset connects the call.

Whilst the liquidstate post was very helpful in configuration it omitted to given the Dial Plan showing how to use it.

Many thanks for making me investigate in the right direction.