[SOLVED] No Playback/Echo on any SoftPhone with SIP

Hi, I am new to Asterislk, and i’m trying to setup and test a system for a company.

I managed to install everything on a server with a Digium TE410PE card. I first only want to test VoIP, so the system performances with lots of phones etc.

The thing is, I can make a connection between 2 softphones on 2 different computers. What does not work, is the PlayBack function. I already searched through the forum, but most problems are with hardphones.

the dial plan

exten => 100,1,Dial(SIP/rule)
exten => 150,1,Dial(SIP/wim)
exten => 611,1,Echo()
exten => 200,1,Playback(demo-thanks)		; "Thanks for trying the demo"



zapata.conf (not that it is necesarry for SIP, but i thought maybe it helps if i make some ) channels…

signalling = pri_cpe
group = 2
channel => 1-15

I tried both the X-lite and the Nero Sipps. The sound files are all owned by the owner the asterisk process (both root).

Asterisk output:

    -- Registered SIP 'wim' at port 51852 expires 3600
    -- Saved useragent "X-Lite release 1003l stamp 30942" for peer wim
    -- Executing Playback("SIP/wim-0968fc88", "demo-thanks") in new stack
    -- Playing 'demo-thanks' (language 'en')

I already tried some codecs, but that seems weird to me anyway, cause all codecs are supported by the clients and just talking goes fine. Anyone any idea?

Thank you very much in advace :smile:

Anyone… :frowning: ? Maybe it is a very simple question, but i still can’t find it…

try adding to sip.conf sections

Thank you for the help. However, it is not working and it seems that the codecs are allright. Phoning between softphones works good, only audio streams don’t play.

*CLI> sip show channel 1669636608-4893d632@ 

  * SIP Call
  Direction:              Incoming
  Call-ID:                1669636608-4893d632@
  Our Codec Capability:   4
  Non-Codec Capability:   0
  Their Codec Capability:   1054
  Joint Codec Capability:   4
  Format                  ulaw
  Theoretical Address:
  Received Address:
  NAT Support:            RFC3581
  Audio IP:      (local)
  Our Tag:                as55f99d4b
  Their Tag:              6384a243
  SIP User agent:         Nero SIPPS IP Phone Version
  Username:               rule
  Peername:               rule
  Original uri:           sip:rule@
  Caller-ID:              rule
  Need Destroy:           0
  Last Message:           Rx: ACK
  Promiscuous Redir:      No
  Route:                  sip:rule@
  DTMF Mode:              rfc2833
  SIP Options:            (none)

and show channell:

*CLI> show channel SIP/rule-091617e0
 -- General --
           Name: SIP/rule-091617e0
           Type: SIP
       UniqueID: 1155115600.2
      Caller ID: rule
 Caller ID Name: rulysipps
    DNID Digits: 200
          State: Up (6)
          Rings: 0
   NativeFormat: 4
    WriteFormat: 2
     ReadFormat: 4
1st File Descriptor: 9
      Frames in: 27702
     Frames out: 1
 Time to Hangup: 0
   Elapsed Time: 0h9m12s
  Direct Bridge: <none>
Indirect Bridge: <none>
 --   PBX   --
        Context: internal
      Extension: 200
       Priority: 2
     Call Group: 0
   Pickup Group: 0
    Application: Playback
           Data: demo-thanks
    Blocking in: ast_waitfor_nandfds

  CDR Variables:
level 1: clid="rulysipps" <rule>
level 1: src=rule
level 1: dst=200
level 1: dcontext=internal
level 1: channel=SIP/rule-091617e0
level 1: lastapp=Playback
level 1: lastdata=demo-thanks
level 1: start=2006-08-09 11:26:40
level 1: answer=2006-08-09 11:26:40
level 1: end=2006-08-09 11:26:40
level 1: duration=0
level 1: billsec=0
level 1: disposition=ANSWERED
level 1: amaflags=DOCUMENTATION
level 1: uniqueid=1155115600.2

I’m a bit out of ideas…


I had this same problem with my SIP phones. I could get tones (such as from the Congestion() application), but I couldn’t hear any voice prompts or MP3’s, even though it looked like Asterisk was playing them.

Finally, I decided to try removing the zaptel modules from the kernel… then I shut down Asterisk and started it back up, and BANG, the voice prompts worked!

It sounds like you may be having the same problem. To see if any zaptel modules are loaded, run:

lsmod|grep zaptel

It should show one line that begins with zaptel and lists other modules at the end, separated by commas. Then to remove the modules, run:


where is the name of each module listed by lsmod, and then:

rmmod zaptel

That should do it. Then restart Asterisk.

I suspect it’s because I haven’t configured the Digium devices yet, but they’re installed in the machine, so Linux detects them and loads the drivers, and when Asterisk tries to use them it breaks stuff. Hopefully once the devices are properly configured, the SIP stuff will still work!

Anyhow… good luck!

YES!! FINALLY! Thank you so much!

I had exactly the same problem, not properly configured Digium devices…

Tonight i’m going to put a statue in my livingroom with “cmdrwalrus” on it and burn candles in front of it… :wink: