[SOLVED] No internal ext to ext calls on new install

I am new to asterisk, and am setting a system for our office, and after following the basic install instructions, I could not get internal calls to work, whether it be from ‘softphone to softphone’ or ‘hardphone to hardphone’ or ‘softphone to harphone’ or ‘hardphone to softphone’.

Whenever I called, for example, from x1001 to x1002, if x1002 had voicemail enabled it would immediately go to voicemail without ringing. If voicemail was disabled on x1002 then I would get either a busy signal or a ‘the person you are calling is unavailable. please try again’ message.

I have been searching this and other forums for two weeks trying to figure out what I did wrong… FINALLY I had a brainstorm, and the answer was so obvious that I had to share in case there are other newbies making the same silly mistake…

The problem was that when I tried to call another extension, I was prefixing it with a star like this: *1002

The solution is that you do NOT prefix the extension number with a star when calling internally… you simply dial the extension number like this: 1002

I am still not sure why it goes directly to the extensions voicemail when you prefix with the star (*1002), but at least I can now make internal calls succesfully!

Hope this helps somebody else!!!