[SOLVED] Installing SIPP for Asterisk Installed in Virtual Machines

Hello all! first of all, let me introduce myself as a last year college student that have a bit of a problem in my newly-started Asterisk IP-PBX project.

My intention is to build a very basic IP-PBX server with AsteriskNOW running on virtual machine to support communication purpose in a small building, with the server running on virtual machine with my laptop as the host, as for now, the system is running quite flawlessly, all extension is able to place a call without any problem.

The problem is, now i want to measure how much traffic, or concurrent call, this IP-PBX server can take until it will fell flat on its face, i tried installed SIPp but there is a problem with the instalation as the asterisk keeps popping out “connection closed by peers” as i executing this command

wget http://sourceforge.net/projects/sipp/files/sipp/3.0/sipp-3.0.src.tar.gz/download

Is there any other way that i can measure the server’s capacity, i found a program that will do stuff similar to the SIPp, but its limited to 50 concurrent calls.

This is not abut Asterisk.

You should be able to find RPM packages for SIPP (I could a few months ago). Otherwise look for the tarball from first principles.

If your problem is persistent, it may well be an anti-evasion measure by sourceforge. Remember SF make their money from the adverts, and using a downloader, like wget, will bypass the adverts. The way round that is simple; download using a normal web browser, possibly even under Windows.

Thank you for your response david!

But, i am very new to the Asterisk and CentOS itself, i happen to find the .rar package file for SIPp 3.5.1, is there any way that i can find help for installing this rar.files?

.rar is an archive format, not a package format. There should be an unrar tool available for CentOS, although you may need to download the package for that.

I feel u mate. I was in the same position. Luckily - I stumbled upon this : Install guide
Followed the guide step by step and all was alive and well :slight_smile:

He is trying to use SIPp, not SIPML.

The last time I installed it, I just downloaded the package and did yum localinstall on it. However, I cannot remember exactly where I found the RPM, although there are various search sites you can use, and I don’t know which version of CentOS AsteriskNOW currently uses.

(I’ve also installed from source, a few years ago.)

In all cases, I downloaded under Windows and then transferred the file using an sftp client.

Well, it is solved for now! seems very silly but it’s all just caused by my strict campus internet policy, the wget command work well in my house!