SOLVED - Double DTMF on outbound calls

The solution for me was to turn off hardware dtmf detection on my PRI card.

I hope this saves someone a days work+headache :smile:


OK, so after a lot of reading and starring at logsā€¦

I tried a test call to my cell phone, picked it up, and dialed numbers, and to my surprise the tones are doubledā€¦so instead of beep I get beep,beep (DTMF length in log says its 80ms)

So, to correct my original post, itā€™s not that remote IVRs arenā€™t hearing my DTMF, they are hearing double digits - ignore my bs below :smile:

This still does not explain why a softphone works fine, but if I call our PBX via an analog telephone, and dial out that way, the tones are doubled. Furthermore, when I dial into asterisk via analog phone, I am prompted for my pin which is taken fine, same for the desired # , once the connection is established, thatā€™s when the trouble begins.

Also, Asterisk connects to the PSTN via Sangoma A101DE the line type is PRI - what type of DTMF should I use? inband? rfc2833?

In response to a comment about inbandā€¦ we have ulaw and alaw enabledā€¦that is G.711 right?

OLD POST_________________________________________
I posted this question elsewhere, but I will attempt to re-state my question here.

We are using Asterisk with the A2billing module and FreePBX web GUI.

DTMF works great over softphones (SIP and IAX)

However, we have some remote telemarketers that dial an 800 # to access our system. They then enter a calling card PIN, and then dial the desired number. Everything up to that point works great. The trouble starts when they connect to various IVRs - some can hear our DTMF and some cannot. I have read elsewhere that setting the DTMF to in-band will fix this issueā€¦I believe I have already tried this.

I was told modifying the DTMF on a per-extension basis would fix this, however, the users that are having the problems donā€™t really have an extension, instead they dial in VIA an 800 number (We have it set as a in-bound route, no worries there)

any suggestions? I am using asterisk version 1.6.2.6 , freepbx version 2.7.0.2 . . .

In band DTMF will only work with G.711 codecs.

You really need to create debug traces at the SIP and possibly RTP levels to be able to understand why things are not working. Also you need to show your dialplan.

edit -removed irrelevant info

EDIT - removed irrelevant info