[SOLVED] Compile asterisk 13.22.0


#1

hi
i am trying to compile asterisk 13.22.0 from source and i got below error

[CC] res_pjsip/config_transport.c -> res_pjsip/config_transport.o
res_pjsip/config_transport.c: In function ‘cipher_name_to_id’:
res_pjsip/config_transport.c:982:24: error: ‘PJ_SSL_SOCK_MAX_CIPHERS’ undeclared (first use in this function)
pj_ssl_cipher ciphers[PJ_SSL_SOCK_MAX_CIPHERS];
^
res_pjsip/config_transport.c:982:24: note: each undeclared identifier is reported only once for each function it appears in
res_pjsip/config_transport.c:982:16: warning: unused variable ‘ciphers’ [-Wunused-variable]
pj_ssl_cipher ciphers[PJ_SSL_SOCK_MAX_CIPHERS];
^
res_pjsip/config_transport.c: In function ‘handle_pjsip_list_ciphers’:
res_pjsip/config_transport.c:1106:24: error: ‘PJ_SSL_SOCK_MAX_CIPHERS’ undeclared (first use in this function)
pj_ssl_cipher ciphers[PJ_SSL_SOCK_MAX_CIPHERS];
^
res_pjsip/config_transport.c:1106:16: warning: unused variable ‘ciphers’ [-Wunused-variable]
pj_ssl_cipher ciphers[PJ_SSL_SOCK_MAX_CIPHERS];
^
/usr/src/asterisk-13.22.0/Makefile.rules:149: recipe for target ‘res_pjsip/config_transport.o’ failed
make[1]: *** [res_pjsip/config_transport.o] Error 1
Makefile:387: recipe for target ‘res’ failed
make: *** [res] Error 2


#2

How have you built PJSIP? Are you using bundled[1]? If not you should.

[1] https://blogs.asterisk.org/2016/03/16/asterisk-13-8-0-now-easier-pjsip-install-method/


#3

why?
before then i was asterisk 13.13.1 and without bundle and now i compile asterisk 13.21.1 without bundle and compile successfully


#4

If you read the blog post you can see why I recommend bundle - it guarantees a known working version of PJSIP which is usually up to date and includes fixes which are not yet in a release. It provides the best experience.


#5

thank you, i will check
another question , i have asterisk 13.21.1 and its high load on above 45 concurrent call
should i create new topic?


#6

i install with bundle and it’s work
thank you


closed #7