SIP-to-Zap call: one way audio problem after FreePBX install


Until last week I had a functional Asterisk 1.2+OpenSER+MediaProxy set-up (calls ok both ways between Zap and SIP).

I then installed FreePBX to provide a GUI to the whole thing. After some changes in the default config files from FreePBX (since it replaces some of your Asterisk config files), I realized I had no sound in the Zap-to-SIP calls (and the other way round) in the SIP end. I didn't change anything relative to the codecs. The only thing that is even remotely related to the problem is that I changed the ports in rtp.conf from 10000~20000 to 10001~20000. I changed SIP.conf but only to restore the integration with OpenSER.

The SIP client (SJPhone) is the same as before but now with this problem, it seems to think that the codec is not set for the Asterisk-SIP way. The other way is set to ulaw (I allow ulaw and alaw on the Asterisk box). The SIP phones are on the same network as the Asterisk box. There should be no NAT issues.

I tried to check the SIP messages in Asterisk to see if there was a problem in the codec negociation but I couldn't find any (which doesn't mean there isn't any).

However, SIP-to-H323 calls (and the other way round) work fine, but not the Background() command when playing a file to a SIP phone. I also tried removing OpenSER of the path and still no audio.

I compared the codec settings before and after the install and couldn't find any difference. I then restored my config files as they were previously but it still doesn't work...

I know the whole setup is not Asterisk only but I think the solutions boils down to solving that codec problem in Asterisk.

Any idea?

Thank you,