SIP problem with Forcerport

Hi guys,

I’m new to the Asterisk PBX and I don’t have a lot of experience. I try to configure an Asterisk PBX from one phone to another with SIP trunking by using a Toll-free Phone number.

I follow a tutorial on youtube to install Asterisk the I follow each and every step. My SIP Probiver is onsip.
I’m unable to make calls with my number when I type sip show peers I get:

Name/username             Host                                    Dyn Forcerport Comedia    ACL Port     Status      Description                      
201/201                                     D  Yes        Yes            55675    UNREACHABLE                                  
202/202                                     D  Yes        Yes            56799    UNREACHABLE                                  
trunk/90991                                  Auto (No)  No             5060     UNREACHABLE                                  
3 sip peers [Monitored: 0 online, 3 offline Unmonitored: 0 online, 0 offline]

I see that Forcerport are is set as Auto (No) and I was thinking it might be the problem.
If it’s the problem how could I enable it?

Auto should be fine. The chances are that you don’t need to force it on 201 or 202, either. Forcing rport is only needed if peer is giving you an address in Via headers that doesn’t match the address to which you have to respond, and that should not be a problem with service providers, even when NAT is involved at your end; they would need a silly configuration at their end.

How have you told Asterisk its address on the public side of the router?

Also, if you are just starting, you should not be using chan_sip, as that is going to be removed in the near future; you should be using chan_pjsip.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.