SIP Parser Error : Missing '@', line 1, column 22 for 800 #s

I have a new SIP and long distance (xxx)xxx-xxxx works fine but when I cal (800)xxx-xxxx Asterisk generates the following error resulting in the call failing through:

Got SIP response 400 “SIP Parser Error : Missing ‘@’, line 1, column 22” back from 207.47.133.4

Here is the complete log entry:

[Oct 10 20:38:13] VERBOSE[9958] logger.c:     -- Executing [18004633339@outgoing:1] Dial("SIP/203-081d7aa8", "SIP/webcall_sip_proxy/8004633339}") in new stack
[Oct 10 20:38:13] VERBOSE[9958] logger.c:     -- Called webcall_sip_proxy/8004633339}
[Oct 10 20:38:13] VERBOSE[9820] logger.c:     -- Got SIP response 400 "SIP Parser Error : Missing '@', line 1, column 22" back from xxx.xxx.xxx.xxx [Oct 10 20:38:13] VERBOSE[9958] logger.c:     -- SIP/webcall_sip_proxy-08201a18 is circuit-busy
[Oct 10 20:38:13] VERBOSE[9958] logger.c:   == Everyone is busy/congested at this time (1:0/1/0)

The call can be successfully place with their Linksys SPA1001 they provided so I am assuming it is Asterisk causing the problem

Anyone seen this before?

Dion

“set sip debug” via the CLI. capture all the SIP messages and take a look at them, see if anything jumps out at you. If you don’t see anything weird, post up the message log and somebody may see something.

As I mentioned before, it only appears to be 1800 and 1888 and 1877 etc that fail. local and other area codes all seem fine. Any ideas?

SIP Debugging enabled
The ‘sip debug’ command is deprecated and will be removed in a future release. Please use ‘sip set debug’ instead.
Really destroying SIP dialog '5b94edef26cae1c927f73c4e574b1a50@webcall.ca’ Method: REGISTER
– Accepted AUTHENTICATED TBD call from 192.168.100.101
– Accepting DIAL from 192.168.100.101, formats = 0x4
– Executing [18008474096@outgoing:1] Dial(“IAX2/202-1”, “SIP/webcall_sip_proxy/8008474096}”) in new stack
Audio is at 192.168.100.10 port 17746
Adding codec 0x4 (ulaw) to SDP
Adding codec 0x2 (gsm) to SDP
Adding codec 0x8 (alaw) to SDP
Reliably Transmitting (no NAT) to 207.47.133.4:5060:
INVITE sip:8008474096}@webcall.ca SIP/2.0
Via: SIP/2.0/UDP 192.168.100.10:5060;branch=z9hG4bK140ed73d;rport
From: “202” sip:xxxxxxxxxx@webcall.ca;tag=as63b63fc8
To: sip:8008474096}@webcall.ca
Contact: sip:xxxxxxxxxx@192.168.100.10
Call-ID: 53955f662b69b8987b1683ac5e12fe33@webcall.ca
CSeq: 102 INVITE
User-Agent: Asterisk PBX
Max-Forwards: 70
Date: Sun, 19 Oct 2008 19:07:18 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Content-Type: application/sdp
Content-Length: 233

v=0
o=root 6612 6612 IN IP4 192.168.100.10
s=session
c=IN IP4 192.168.100.10
t=0 0
m=audio 17746 RTP/AVP 0 3 8
a=rtpmap:0 PCMU/8000
a=rtpmap:3 GSM/8000
a=rtpmap:8 PCMA/8000
a=silenceSupp:off - - - -
a=ptime:20
a=sendrecv


-- Called webcall_sip_proxy/8008474096}

nas*CLI>
<— SIP read from 207.47.133.4:5060 —>
SIP/2.0 400 SIP Parser Error : Missing ‘@’, line 1, column 22
From: "202"sip:xxxxxxxxxx@webcall.ca;tag=as63b63fc8
To: sip:8008474096}@webcall.ca
Call-ID: 53955f662b69b8987b1683ac5e12fe33@webcall.ca
CSeq: 102 INVITE
Via: SIP/2.0/UDP 192.168.100.10:5060;received=70.64.xxx.xxx;rport=5060;branch=z9hG4bK140ed73d
User-Agent: Asterisk PBX
Max-Forwards: 70
Supported: replaces
Date: Sun, 19 Oct 2008 19:07:18 GMT
Allow: INVITE,ACK,CANCEL,OPTIONS,BYE,REFER,SUBSCRIBE,NOTIFY
Content-Type: application/SDP
Content-Length: 233

v=0
o=root 6612 6612 IN IP4 192.168.100.10
s=session
c=IN IP4 192.168.100.10
t=0 0
m=audio 17746 RTP/AVP 0 3 8
a=rtpmap:0 PCMU/8000
a=rtpmap:3 GSM/8000
a=rtpmap:8 PCMA/8000
a=silenceSupp:off - - - -
a=ptime:20
a=sendrecv

<------------->
— (13 headers 12 lines) —
– Got SIP response 400 “SIP Parser Error : Missing ‘@’, line 1, column 22” back from 207.47.133.4
Transmitting (no NAT) to 207.47.133.4:5060:
ACK sip:8008474096}@webcall.ca SIP/2.0
Via: SIP/2.0/UDP 192.168.100.10:5060;branch=z9hG4bK140ed73d;rport
From: “202” sip:xxxxxxxxx@webcall.ca;tag=as63b63fc8
To: sip:8008474096}@webcall.ca
Contact: sip:xxxxxxxxxx@192.168.100.10
Call-ID: 53955f662b69b8987b1683ac5e12fe33@webcall.ca
CSeq: 102 ACK
User-Agent: Asterisk PBX
Max-Forwards: 70
Content-Length: 0


-- SIP/webcall_sip_proxy-081c1d88 is circuit-busy

Here is your issue:

REGISTER
– Accepted AUTHENTICATED TBD call from 192.168.100.101
– Accepting DIAL from 192.168.100.101, formats = 0x4
– Executing [18008474096@outgoing:1] Dial(“IAX2/202-1”, "SIP/webcall_sip_proxy/8008474096}") in new stack
Audio is at 192.168.100.10 port 17746
Adding codec 0x4 (ulaw) to SDP
Adding codec 0x2 (gsm) to SDP
Adding codec 0x8 (alaw) to SDP
Reliably Transmitting (no NAT) to 207.47.133.4:5060:
INVITE sip:8008474096}@webcall.ca SIP/2.0

Looks like you have a curly brace after your number for some reason…

Thanks - that was exactly the problem. Its no nice to have another set of eyes to look at things.

thanks again!