SIP over TCP/IP


#1

SIP over TCP/ IP is not currently working for me.

I have been googling all day and haven’t found a solution…

Here is the example
Tried editing sip.conf

[sip]
type=friend ; we only want to call out, not be called
host=proxy01.xxxxxxx.com
context=xxxxxxxxxxx
protocol=tcp

Tried editing extensions.conf

exten => _+.,1,Dial(SIP/${EXTEN}@{sip})
exten => _+.,2,Playback(notavail)
exten => _+.,3,Busy
transport=tcp

but when i reload everything and do an

lsof -i

It still doesn’t show asterisk listening on port 5060, any ideas on this.

Thanks


#2

forgive me if this is hella-obvious but it’s necessary to check :

You don’t happen to have a statement in modules.conf that’s stopping the sip module from being loaded do you ? If you see something like “noload => chan_sip.so” in your modules.conf, and you’re using autoload, get rid of it. If not, it seems as if your sip module may not be in the modules dir, or you have a 1.0.x module in a 1.2.x directory. I’m not versed enough to know if your sip/extensions syntax is completely correct, but syntax errors should not be causing the module to not load, which is the #1 reason for udp/5060 to not be listening.