SIP/IAX inbound not working on IP01 via voiptalk.org

Hi

New to asterisk and have a IP01 unit from Atcom which is an embedded device with a web front end, although you can run CLI commands and edit the .conf files directly.

I’ve managed to set up the extensions, dial plans, outbound trunks etc etc, and can get outbound calls to work over POTS and the SIP trunks.

BUT i can’t seem to get inbound calls working.

I use voiptalk.org in the UK and they offer SIP and IAX inbound.

So I trying IAX first as from what I read its easier with NAT and Firewall etc.

voiptalk require IAX ‘activation’ on the accounts I want to use IAX with and via their support they have turned this on.

When I dial the number inbound and look in the syslog I can see something hitting the box as I get

Jun 18 09:48:01 10.10.18.15 Jun 18 08:47:58 asterisk[188]: NOTICE[188]: chan_iax2.c:8258 in socket_process: Registration of ‘84413790’ rejected: ‘Registration Refused’ from: '217.14.138.130’
Jun 18 09:48:02 10.10.18.15 Jun 18 08:47:58 asterisk[188]: VERBOSE[188]: Tx-Frame Retry[-01] – OSeqno: 001 ISeqno: 001 Type: IAX Subclass: ACK
Jun 18 09:48:02 10.10.18.15 Jun 18 08:47:58 asterisk[188]: VERBOSE[188]: Timestamp: 00005ms SCall: 00138 DCall: 04913 [217.14.138.130:4569]
Jun 18 09:48:47 10.10.18.15 Jun 18 08:48:48 asterisk[197]: VERBOSE[197]: Tx-Frame Retry[000] – OSeqno: 000 ISeqno: 000 Type: IAX Subclass: REGREQ
Jun 18 09:48:48 10.10.18.15 Jun 18 08:48:48 asterisk[197]: VERBOSE[197]: Timestamp: 00003ms SCall: 00238 DCall: 00000 [217.14.138.130:4569]
Jun 18 09:48:48 10.10.18.15 Jun 18 08:48:48 asterisk[197]: VERBOSE[197]: USERNAME : 84413790
Jun 18 09:48:48 10.10.18.15 Jun 18 08:48:48 asterisk[197]: VERBOSE[197]: REFRESH : 60

Any body got any ideas?

The alternative is to try SIP, which should work out the box. When I tried this before I was getting errors like

Jun 09 02:23:26 10.10.18.15 Jun 9 01:23:26 asterisk[183]: NOTICE[183]: chan_sip.c:14377 in handle_request_invite: Call from ‘834220345’ to extension ‘02033845936’ rejected because extension not found.

834220345 is the voiptalk account and 02033845936 is one of the numbers that they given me. So maybe just a config issue?

Any body got any ideas? I’m happy to work with SIP or IAX, just wanna get the thing working.

OK starting to solve this. They don’t support IAX registration outbound. So that’s fixed.

The inbound problem remains:

OK.

Sorted the resigration issue, I can use SIP and it works just fine. They all registered.

Just the incoming IAX problem now.

Jun 18 13:19:17 10.10.18.15 Jun 18 12:19:17 asterisk[187]: NOTICE[187]: chan_iax2.c:7561 in socket_process: Rejected connect attempt from 77.240.54.10, who was trying to reach ‘02070436937@’

So it’s definitely hitting the box when I try to call in.

Please tell me what my iax.conf file should look like.

Atm iax.conf looks like this:
[general]
bandwidth=low
jitterbuffer=no
forcejitterbuffer=no
autokill=yes
adsi=no
authdebug=yes
bindaddr=10.10.18.15
bindport=4569
codecpriority=reqonly
delayreject=no
dropcount=
iaxcompat=no
iaxmaxthreadcount=100
iaxthreadcount=10
jittershrinkrate=
language=en
maxexcessbuffer=
maxjitterbuffer=1000
maxjitterinterps=10
maxregexpire=60
minexcessbuffer=
minregexpire=60
mohinterpret=default
mohsuggest=
nochecksums=no
resyncthreshold=1000
tos=
trunkfreq=20
trunktimestamps=no
disallow=all
allow=undefined,ulaw,alaw,gsm

[02070436937]
context=from-pstn
type=friend
username=02070436937@

What in there would be causing the rejection?

This is their docs on trixbox, although I have a IP01

voiptalk.org/products/trixbo … setup.html

Thanks

try putting

calltokenoptional = 0.0.0.0/0.0.0.0
maxcallnumbers = 999

in your iax.conf general section

I used voiptalk.org and these are my iax.conf trunk settings:

[0870xxxxxxx]
context=from-pstn
type=user
username=0870xxxxxxx

(I’ve masked part of the above number)

[voiptalk]
host=iax.voiptalk.org
qualify=yes
secret=(password for voiptalk ID)
type=peer
username=(voiptalk ID - e.g. 8412345)

That works for me. Please an inbound route for the above 0870 number to route it to an internal ring group or extension or whatever you want.

You can configure Asterisk using 2 methods:

Configuration using only extensions.conf file:

This involves adding the following entries into extensions.conf:
exten => _0[1-9].,1,Dial(IAX2/USERID:PW@iax.voiptalk.org/44${EXTEN:1})
exten => _00.,1,Dial(IAX2/USERID:PW@iax.voiptalk.org/${EXTEN:2})
where USER is the user ID, and PW is the password.

The first line of the dial sequence allows UK-based customers to dial without a country code as it substitutes the prefixed 0 with a 44. This method is the least secure, as the dial sequence including the password will appear on the console display when an outgoing call is made.
Configuration using iax.conf:

The preferred method of configuring Asterisk is by using a combination of the iax.conf and extensions.conf files. The iax.conf file enables you to have much more configuration control over your iax connection, allowing you to control things such as codec priorities, trunking etc.

For connection to voiptalk, a basic iax.conf entry would be:
[voiptalk]
type=peer
username=USERID
secret=PW
host=iax.voiptalk.org
The corresponding extensions.conf would be:
exten => _0[1-9].,1,Dial(IAX2/USERID@voiptalk/44${EXTEN:1})
exten => _00.,1,Dial(IAX2/USERID@voiptalk/${EXTEN:2})
Dialling Other Networks:

Please configure your extensions.conf locally for other networks. Our special test numbers 90X cannot be used over the IAX protocol.

in Asterisk 1.6.1.6 you will need to add this parameter below in to the inbound number section in the iax.conf.
calltokenoptional=0.0.0.0/0.0.0.0
Reference : voiptalk.org/products/config … talk-setup