Show file formats returns 0 file formats registered

Hi all,

When I run "show file formats" in the CLI for Asterisk, I get back an empty table and a line saying "0 file formats registered".  I have done a lot of browsing and cannot figure out how to add a file format.  I've uncommented both of the allow= lines:

allow=ulaw allow=alaw
but I can’t seem to get it to work. Any suggestions? This is a 100% stock install right now minus those two uncommented lines.


A stock install from what source?


Hi Buddy,

It depends on your installation and configuration. More details are needed for help. Which version and what’s your configure.
We can chat by email would be more convenient.My email:

[quote=“michaelbryant81”]Hi Buddy,

It depends on your installation and configuration. More details are needed for help. Which version and what’s your configure.
We can chat by email would be more convenient.My email:[/quote]

It’d be better for the board to not take this conversation private as keeping it knowledge here benefits a wider audience. Do you disagree?

this person has these suggestions to take threads private via email chat all over the place. definitely not cool.

Looked at their post history and I see the same thing.

I’ll send them a PM warning.

Wow, sorry for not replying, I was expecting to get email alerts on replies. Checked that box now. Anyway…

This is a Windows install from Hopefully that shouldn’t be a problem though. If it is, then I do have a spare box; would you recommend burning and running the live CD? What I want to do in the long run is essentially have a script that queries an external web page that will change every so often; and when it changes I want the message sent out when you call this number changed. I am a pretty good programmer (if I do say so myself) and can do all of this easily enough by rewriting the config file and restarting the server, but I need to have the server working before I can do that!


Ick. Sorry, not going to be able to help you that. What you got from that location is hopelessly old and not something that most of the people here are familiar with. Can you do a regular install of Asterisk on a generic Linux machine, or perhaps an install of AsteriskNOW?


That’s exactly what I wanted to hear. I’m installing that right now. Gotta love saving those old boxes for ‘something’ :laughing:

Alright, so I installed that now, and am getting another similar issue to what I started with. I set up Asterisk to work with my Gizmo5 by listening for incoming calls, and handle them with the following rule:

exten => s,1,SayDigits(1234)
exten => s,2,Playback(demo-congrats)
exten => s,3,Hangup

And when I place a test call, I see the following in the console for Asterisk:

-- Executing [s@from-sip-external:1] SayDigits("SIP/", "1234") in new stack -- <SIP/> Playing 'digits/1' (language 'en') -- <SIP/> Playing 'digits/2' (language 'en') -- <SIP/> Playing 'digits/3' (language 'en') -- <SIP/> Playing 'digits/4' (language 'en') -- Executing [s@from-sip-external:2] Playback("SIP/", "demo-congrats") in new stack -- <SIP/> Playing 'demo-congrats' (language 'en') == Parsing '/etc/asterisk/manager.conf': Found == Parsing '/etc/asterisk/manager_additional.conf': Found == Parsing '/etc/asterisk/manager_custom.conf': Found == Manager 'admin' logged on from == Spawn extension (from-sip-external, s, 2) exited non-zero on 'SIP/'

Which to me looks like it is working right. But I don’t hear anything. I know for a fact that my softphone is configured correctly because the call is obviously going through, and I can hear a voice when I dial an incorrect number. Any suggestions? Will post any files if told to, and this is a AsteriskNOW install using option 2, version 1.4 with OpenPBX.

Bumping. I am actually checking the forum here. Anyone have any clue why I can’t hear anything? I can post more logs, etc. if needed! Thanks!


If you connect a softphone directly to Asterisk, do you have this problem?

Or, is it only a problem that occurs when trying to connect via the Gizmo network?

Free softphones include Xlite and Zoiper.


I do plan on doing this, but I have been very busy so haven’t gotten around to it yet. Will be able to do it Sunday probably, so don’t consider me MIA yet 8)

AHA! I added a test SIP user and an identical extension to the one I was testing and it works!! I go back and try the Gizmo5 call though and it works fine!!! :smiley: I have no idea what I screwed up, but I did get this working. Thank you for being patient :stuck_out_tongue: