Should we switch this ON or OFF "transcode_via_sln = no

Hi All,

I am having difficulty with choppy sound quality.

I have installed the following on a Dell-1650 dual CPU server:

Asterisk 1.4.18
Zaptel 1.4.10
Asterisk-addons 1.4.6
FreePBX 2.4
A2Billing 1.3.2

Immediately after the installation, getting excited after a no glitch setup, I configured my SIP trunk and few extensions. I made a call over my SIP trunk to a PSTN number. The quality was bad so I decided to make a call to another IP phone, the quality was better but plenty of choppy sound.

Now this is not my first install, I have been using Trixbox, pbxinaflash for some time now (with the same provider) and I can say that the quality with TB was the best. (no choppiness)

Only reason for me to go pure Asterisk is to get rid of the clutter, that the likes of TB comes with, hoping for even better quality.

But for some reason it became worse.

I have noticed “transcode_via_sln = no” under options in asterisk.conf.

What is the default setting, is it ON or OFF. Is it better if we switch it ON or OFF?

Your thoughts are appreciated.

any one?