SDP address set to loopback address when using trunk

Hi all,

I’m trying to setup a trunk with Asterisk behind a NAT, but I’m running into a weird issue. It works perfectly for the first 24-48 hours, then it starts sending SDP packets using a loopback address (127.0.0.2). I’ve fiddled with the config for a few weeks and I can’t seem to figure it out. Any help on what is wrong with my config would be appreciated.

Logs
First appearance of loopback address

OS: Fedora 32
Packages: 1
asterisk-pjsip-17.4.0-2.fc32.x86_64
asterisk-sounds-core-en-1.6.1-7.fc32.noarch
asterisk-17.4.0-2.fc32.x86_64
asterisk-sounds-core-en-alaw-1.6.1-7.fc32.noarch

Is your xxx.duckdns.org address failing to resolve as expected ?

Check also your /etc/asterisk/dnsmgr.conf file.

Thanks for the response! I failed to explicitly mention this in the initial post, but restarting asterisk after the issue starts appearing does make it work again temporarily.

Is your xxx.duckdns.org address failing to resolve as expected ?

No, I can dig the address just fine from the asterisk server, and my IP does not change that often. I have not edited dnsmgr.conf, I will turn it on and see if it helps.

It’s been a few days and it still works! dnsmgr just needed to be enabled. Thanks a ton @penguinpbx

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.